Read the docs
TI-2025-41984 Aliases CVE-2025-68436GHSA-53vf-c43h-j2x9

Craft CMS vulnerable to potential information disclosure via unchecked asset relocation

Priority LOW 22CWE-200Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Attack requirements
None
Impact type
Information disclosure
Confidentiality · integrity · availability
High · None · None
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-200.

Summary

Craft is a platform for creating digital experiences. In versions 5.0.0-RC1 through 5.8.20 and 4.0.0-RC1 through 4.16.16, authenticated users on a Craft installation could potentially expose sensitive assets via their user profile photo via maliciously crafted requests. Users should update to the patched versions (5.8.21 and 4.16.17) to mitigate the issue.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00279 20th percentileScored 2026-11-07
Fix Fixed cms (craftcms): 5.8.21, 4.16.17craftcms/cms (Packagist): 5.8.21, 4.16.17

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
Craft CMScms5.0.0-RC1 to before 5.8.21; 4.0.0-RC1 to before 4.16.175.8.21, 4.16.17Patch availableCNA
—craftcms/cms (Packagist)5.0.0-RC1 to before 5.8.215.8.21Patch availableGHSA-53vf-c43h-j2x9
—craftcms/cms (Packagist)4.0.0-RC1 to before 4.16.174.16.17Patch availableGHSA-53vf-c43h-j2x9
  • cms VendorCraft CMS Affected 5.0.0-RC1 to before 5.8.21; 4.0.0-RC1 to before 4.16.17 Fixed in 5.8.21, 4.16.17 Patch available CNA
  • craftcms/cms (Packagist) Vendor— Affected 5.0.0-RC1 to before 5.8.21 Fixed in 5.8.21 Patch available GHSA-53vf-c43h-j2x9
  • craftcms/cms (Packagist) Vendor— Affected 4.0.0-RC1 to before 4.16.17 Fixed in 4.16.17 Patch available GHSA-53vf-c43h-j2x9

CPE configurations NVD · 7

CPEVersionsRoleVendor
cpe:2.3:a:craftcms:craft_cms:*:*:*:*:*:*:*:*4.0.0.1 to before 4.16.17; 5.0.1 to before 5.8.21VulnerableCraft CMS
cpe:2.3:a:craftcms:craft_cms:4.0.0:-:*:*:*:*:*:*4.0.0VulnerableCraft CMS
cpe:2.3:a:craftcms:craft_cms:4.0.0:rc1:*:*:*:*:*:*4.0.0 rc1VulnerableCraft CMS
cpe:2.3:a:craftcms:craft_cms:4.0.0:rc2:*:*:*:*:*:*4.0.0 rc2VulnerableCraft CMS
cpe:2.3:a:craftcms:craft_cms:4.0.0:rc3:*:*:*:*:*:*4.0.0 rc3VulnerableCraft CMS
cpe:2.3:a:craftcms:craft_cms:5.0.0:-:*:*:*:*:*:*5.0.0VulnerableCraft CMS
cpe:2.3:a:craftcms:craft_cms:5.0.0:rc1:*:*:*:*:*:*5.0.0 rc1VulnerableCraft CMS
  • cpe:2.3:a:craftcms:craft_cms:*:*:*:*:*:*:*:* Versions 4.0.0.1 to before 4.16.17; 5.0.1 to before 5.8.21 Vulnerable ·Craft CMS
  • cpe:2.3:a:craftcms:craft_cms:4.0.0:-:*:*:*:*:*:* Versions 4.0.0 Vulnerable ·Craft CMS
  • cpe:2.3:a:craftcms:craft_cms:4.0.0:rc1:*:*:*:*:*:* Versions 4.0.0 rc1 Vulnerable ·Craft CMS
  • cpe:2.3:a:craftcms:craft_cms:4.0.0:rc2:*:*:*:*:*:* Versions 4.0.0 rc2 Vulnerable ·Craft CMS
  • cpe:2.3:a:craftcms:craft_cms:4.0.0:rc3:*:*:*:*:*:* Versions 4.0.0 rc3 Vulnerable ·Craft CMS
  • cpe:2.3:a:craftcms:craft_cms:5.0.0:-:*:*:*:*:*:* Versions 5.0.0 Vulnerable ·Craft CMS
  • cpe:2.3:a:craftcms:craft_cms:5.0.0:rc1:*:*:*:*:*:* Versions 5.0.0 rc1 Vulnerable ·Craft CMS

Remediation

  • Fix · CNA cms (craftcms) Fixed in 5.8.21, 4.16.17
  • Fix · GHSA-53vf-c43h-j2x9 craftcms/cms (Packagist) Fixed in 5.8.21 Advisory →
  • Fix · GHSA-53vf-c43h-j2x9 craftcms/cms (Packagist) Fixed in 4.16.17 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-68436
  2. 2026-10-03 Alias added: GHSA-53vf-c43h-j2x9

References

  • TI-2025-23503 Craft CMS Allows Remote Code Execution KEVCVSS 3.1CRITICAL 10.0
  • TI-2024-37138 RCE when PHP `register_argc_argv` config setting is enabled in craftcms/cms KEVCVSS 4.0CRITICAL 9.3
  • TI-2025-16994 Potential RCE with a compromised security key in craft/cms KEVCVSS 3.1HIGH 8.1
  • TI-2025-24595 Craft CMS stores user-provided content in session files KEVCVSS 4.0MEDIUM 6.9
  • TI-2023-22284 Craft CMS Remote Code Execution vulnerability CVSS 3.1CRITICAL 10.0
  • TI-2024-25171 Craft CMS up to v3.7.31 was discovered to contain a SQL injection vulnerability via the GraphQL API endpoint. CVSS 3.1CRITICAL 9.8
See all 96 →

Sources