Read the docs
TI-2025-41985 Aliases CVE-2025-68437GHSA-x27p-wfqw-hfcc

Craft CMS vulnerable to Server-Side Request Forgery (SSRF) via GraphQL Asset Upload Mutation

Priority MEDIUM 56CWE-918Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
None
Attack complexity
Low
Attack requirements
Present
Impact type
Information disclosure
Confidentiality · integrity · availability
High · None · None
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-918 and the CVSS impact.

Summary

Craft is a platform for creating digital experiences. In versions 5.0.0-RC1 through 5.8.20 and 4.0.0-RC1 through 4.16.16, the Craft CMS GraphQL `save_<VolumeName>_Asset` mutation is vulnerable to Server-Side Request Forgery (SSRF). This vulnerability arises because the `_file` input, specifically its `url` parameter, allows the server to fetch content from arbitrary remote locations without proper validation. Attackers can exploit this by providing internal IP addresses or cloud metadata endpoints as the `url`, forcing the server to make requests to these restricted services. The fetched content is then saved as an asset, which can subsequently be accessed and exfiltrated, leading to potential data exposure and infrastructure compromise. This exploitation requires specific GraphQL permissions for asset management within the targeted volume. Users should update to the patched 5.8.21 and 4.16.17 releases to mitigate the issue.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00473 41st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed cms (craftcms): 5.8.21, 4.16.17craftcms/cms (Packagist): 5.8.21, 4.16.17

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
Craft CMScms5.0.0-RC1 to before 5.8.21; 4.0.0-RC1 to before 4.16.175.8.21, 4.16.17Patch availableCNA
—craftcms/cms (Packagist)5.0.0-RC1 to before 5.8.215.8.21Patch availableGHSA-x27p-wfqw-hfcc
—craftcms/cms (Packagist)3.5.0 to before 4.16.174.16.17Patch availableGHSA-x27p-wfqw-hfcc
  • cms VendorCraft CMS Affected 5.0.0-RC1 to before 5.8.21; 4.0.0-RC1 to before 4.16.17 Fixed in 5.8.21, 4.16.17 Patch available CNA
  • craftcms/cms (Packagist) Vendor— Affected 5.0.0-RC1 to before 5.8.21 Fixed in 5.8.21 Patch available GHSA-x27p-wfqw-hfcc
  • craftcms/cms (Packagist) Vendor— Affected 3.5.0 to before 4.16.17 Fixed in 4.16.17 Patch available GHSA-x27p-wfqw-hfcc

CPE configurations NVD · 3

CPEVersionsRoleVendor
cpe:2.3:a:craftcms:craft_cms:*:*:*:*:*:*:*:*3.5.0 to before 4.16.17; 5.0.1 to before 5.8.21VulnerableCraft CMS
cpe:2.3:a:craftcms:craft_cms:5.0.0:-:*:*:*:*:*:*5.0.0VulnerableCraft CMS
cpe:2.3:a:craftcms:craft_cms:5.0.0:rc1:*:*:*:*:*:*5.0.0 rc1VulnerableCraft CMS
  • cpe:2.3:a:craftcms:craft_cms:*:*:*:*:*:*:*:* Versions 3.5.0 to before 4.16.17; 5.0.1 to before 5.8.21 Vulnerable ·Craft CMS
  • cpe:2.3:a:craftcms:craft_cms:5.0.0:-:*:*:*:*:*:* Versions 5.0.0 Vulnerable ·Craft CMS
  • cpe:2.3:a:craftcms:craft_cms:5.0.0:rc1:*:*:*:*:*:* Versions 5.0.0 rc1 Vulnerable ·Craft CMS

Remediation

  • Fix · CNA cms (craftcms) Fixed in 5.8.21, 4.16.17
  • Fix · GHSA-x27p-wfqw-hfcc craftcms/cms (Packagist) Fixed in 5.8.21 Advisory →
  • Fix · GHSA-x27p-wfqw-hfcc craftcms/cms (Packagist) Fixed in 4.16.17 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-68437
  2. 2026-10-03 Alias added: GHSA-x27p-wfqw-hfcc

References

  • TI-2025-23503 Craft CMS Allows Remote Code Execution KEVCVSS 3.1CRITICAL 10.0
  • TI-2024-37138 RCE when PHP `register_argc_argv` config setting is enabled in craftcms/cms KEVCVSS 4.0CRITICAL 9.3
  • TI-2025-16994 Potential RCE with a compromised security key in craft/cms KEVCVSS 3.1HIGH 8.1
  • TI-2025-24595 Craft CMS stores user-provided content in session files KEVCVSS 4.0MEDIUM 6.9
  • TI-2023-22284 Craft CMS Remote Code Execution vulnerability CVSS 3.1CRITICAL 10.0
  • TI-2024-25171 Craft CMS up to v3.7.31 was discovered to contain a SQL injection vulnerability via the GraphQL API endpoint. CVSS 3.1CRITICAL 9.8
See all 96 →

Sources