Craft CMS vulnerable to potential authenticated Remote Code Execution via Twig SSTI
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-1336.
Summary
Craft is a platform for creating digital experiences. Versions 5.0.0-RC1 through 5.8.20 and 4.0.0-RC1 through 4.16.16 are vulnerable to potential authenticated Remote Code Execution via Twig SSTI. For this to work, users must have administrator access to the Craft Control Panel, and allowAdminChanges must be enabled, which is against Craft CMS' recommendations for any non-dev environment. Alternatively, a non-administrator account with allowAdminChanges disabled can be used, provided access to the System Messages utility is available. It is possible to craft a malicious payload using the Twig `map` filter in text fields that accept Twig input under Settings in the Craft control panel or using the System Messages utility, which could lead to a RCE. Users should update to the patched versions (5.8.21 and 4.16.17) to mitigate the issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Craft CMS | cms | 5.0.0-RC1 to before 5.8.21; 4.0.0-RC1 to before 4.16.17 | 5.8.21, 4.16.17 | Patch available | CNA |
| — | craftcms/cms (Packagist) | 5.0.0-RC1 to before 5.8.21 | 5.8.21 | Patch available | GHSA-742x-x762-7383 |
| — | craftcms/cms (Packagist) | 4.0.0-RC1 to before 4.16.17 | 4.16.17 | Patch available | GHSA-742x-x762-7383 |
- cms VendorCraft CMS Affected 5.0.0-RC1 to before 5.8.21; 4.0.0-RC1 to before 4.16.17 Fixed in 5.8.21, 4.16.17 Patch available CNA
- craftcms/cms (Packagist) Vendor— Affected 5.0.0-RC1 to before 5.8.21 Fixed in 5.8.21 Patch available GHSA-742x-x762-7383
- craftcms/cms (Packagist) Vendor— Affected 4.0.0-RC1 to before 4.16.17 Fixed in 4.16.17 Patch available GHSA-742x-x762-7383
CPE configurations NVD · 7
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:craftcms:craft_cms:*:*:*:*:*:*:*:* | 4.0.0.1 to before 4.16.17; 5.0.1 to before 5.8.21 | Vulnerable | Craft CMS |
| cpe:2.3:a:craftcms:craft_cms:4.0.0:-:*:*:*:*:*:* | 4.0.0 | Vulnerable | Craft CMS |
| cpe:2.3:a:craftcms:craft_cms:4.0.0:rc1:*:*:*:*:*:* | 4.0.0 rc1 | Vulnerable | Craft CMS |
| cpe:2.3:a:craftcms:craft_cms:4.0.0:rc2:*:*:*:*:*:* | 4.0.0 rc2 | Vulnerable | Craft CMS |
| cpe:2.3:a:craftcms:craft_cms:4.0.0:rc3:*:*:*:*:*:* | 4.0.0 rc3 | Vulnerable | Craft CMS |
| cpe:2.3:a:craftcms:craft_cms:5.0.0:-:*:*:*:*:*:* | 5.0.0 | Vulnerable | Craft CMS |
| cpe:2.3:a:craftcms:craft_cms:5.0.0:rc1:*:*:*:*:*:* | 5.0.0 rc1 | Vulnerable | Craft CMS |
- cpe:2.3:a:craftcms:craft_cms:*:*:*:*:*:*:*:* Versions 4.0.0.1 to before 4.16.17; 5.0.1 to before 5.8.21 Vulnerable ·Craft CMS
- cpe:2.3:a:craftcms:craft_cms:4.0.0:-:*:*:*:*:*:* Versions 4.0.0 Vulnerable ·Craft CMS
- cpe:2.3:a:craftcms:craft_cms:4.0.0:rc1:*:*:*:*:*:* Versions 4.0.0 rc1 Vulnerable ·Craft CMS
- cpe:2.3:a:craftcms:craft_cms:4.0.0:rc2:*:*:*:*:*:* Versions 4.0.0 rc2 Vulnerable ·Craft CMS
- cpe:2.3:a:craftcms:craft_cms:4.0.0:rc3:*:*:*:*:*:* Versions 4.0.0 rc3 Vulnerable ·Craft CMS
- cpe:2.3:a:craftcms:craft_cms:5.0.0:-:*:*:*:*:*:* Versions 5.0.0 Vulnerable ·Craft CMS
- cpe:2.3:a:craftcms:craft_cms:5.0.0:rc1:*:*:*:*:*:* Versions 5.0.0 rc1 Vulnerable ·Craft CMS
Remediation
- Fix · CNA cms (craftcms) Fixed in 5.8.21, 4.16.17
- Fix · GHSA-742x-x762-7383 craftcms/cms (Packagist) Fixed in 5.8.21 Advisory →
- Fix · GHSA-742x-x762-7383 craftcms/cms (Packagist) Fixed in 4.16.17 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-68454
- 2026-10-03 Alias added: GHSA-742x-x762-7383
References
More Craft Cms vulnerabilities
- TI-2025-23503 Craft CMS Allows Remote Code Execution KEVCVSS 3.1CRITICAL 10.0
- TI-2024-37138 RCE when PHP `register_argc_argv` config setting is enabled in craftcms/cms KEVCVSS 4.0CRITICAL 9.3
- TI-2025-16994 Potential RCE with a compromised security key in craft/cms KEVCVSS 3.1HIGH 8.1
- TI-2025-24595 Craft CMS stores user-provided content in session files KEVCVSS 4.0MEDIUM 6.9
- TI-2023-22284 Craft CMS Remote Code Execution vulnerability CVSS 3.1CRITICAL 10.0
- TI-2024-25171 Craft CMS up to v3.7.31 was discovered to contain a SQL injection vulnerability via the GraphQL API endpoint. CVSS 3.1CRITICAL 9.8
Sources
- CVE-2025-68454 · CVE Program
- CVE-2025-68454 · NVD
- FIRST EPSS
- GHSA-742x-x762-7383 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences