Read the docs
TI-2025-41989 Aliases CVE-2025-68456GHSA-v64r-7wg9-23pr

Unauthenticated Craft CMS users can trigger a database backup

Priority MEDIUM 64CWE-202Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Attack requirements
Present
Impact type
Denial of service
Confidentiality · integrity · availability
High · None · High
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-770.

Summary

Craft is a platform for creating digital experiences. In versions 5.0.0-RC1 through 5.8.20 and 3.0.0 through 4.16.16, unauthenticated users can trigger database backup operations via specific admin actions, potentially leading to resource exhaustion or information disclosure. Users should update to the patched versions (5.8.21 and 4.16.17) to mitigate the issue. Craft 3 users should update to the latest Craft 4 and 5 releases, which include the fixes.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.0056 46th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed cms (craftcms): 5.8.21, 4.16.17craftcms/cms (Packagist): 5.8.21, 4.16.17

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
Craft CMScms5.0.0-RC1 to before 5.8.21; 3.0.0 to before 4.16.175.8.21, 4.16.17Patch availableCNA
—craftcms/cms (Packagist)5.0.0-RC1 to before 5.8.215.8.21Patch availableGHSA-v64r-7wg9-23pr
—craftcms/cms (Packagist)3.0.0 to before 4.16.174.16.17Patch availableGHSA-v64r-7wg9-23pr
  • cms VendorCraft CMS Affected 5.0.0-RC1 to before 5.8.21; 3.0.0 to before 4.16.17 Fixed in 5.8.21, 4.16.17 Patch available CNA
  • craftcms/cms (Packagist) Vendor— Affected 5.0.0-RC1 to before 5.8.21 Fixed in 5.8.21 Patch available GHSA-v64r-7wg9-23pr
  • craftcms/cms (Packagist) Vendor— Affected 3.0.0 to before 4.16.17 Fixed in 4.16.17 Patch available GHSA-v64r-7wg9-23pr

CPE configurations NVD · 3

CPEVersionsRoleVendor
cpe:2.3:a:craftcms:craft_cms:*:*:*:*:*:*:*:*3.0.0 to before 4.16.17; 5.0.1 to before 5.8.21VulnerableCraft CMS
cpe:2.3:a:craftcms:craft_cms:5.0.0:-:*:*:*:*:*:*5.0.0VulnerableCraft CMS
cpe:2.3:a:craftcms:craft_cms:5.0.0:rc1:*:*:*:*:*:*5.0.0 rc1VulnerableCraft CMS
  • cpe:2.3:a:craftcms:craft_cms:*:*:*:*:*:*:*:* Versions 3.0.0 to before 4.16.17; 5.0.1 to before 5.8.21 Vulnerable ·Craft CMS
  • cpe:2.3:a:craftcms:craft_cms:5.0.0:-:*:*:*:*:*:* Versions 5.0.0 Vulnerable ·Craft CMS
  • cpe:2.3:a:craftcms:craft_cms:5.0.0:rc1:*:*:*:*:*:* Versions 5.0.0 rc1 Vulnerable ·Craft CMS

Remediation

  • Fix · CNA cms (craftcms) Fixed in 5.8.21, 4.16.17
  • Fix · GHSA-v64r-7wg9-23pr craftcms/cms (Packagist) Fixed in 5.8.21 Advisory →
  • Fix · GHSA-v64r-7wg9-23pr craftcms/cms (Packagist) Fixed in 4.16.17 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-68456
  2. 2026-10-03 Alias added: GHSA-v64r-7wg9-23pr

References

  • TI-2025-23503 Craft CMS Allows Remote Code Execution KEVCVSS 3.1CRITICAL 10.0
  • TI-2024-37138 RCE when PHP `register_argc_argv` config setting is enabled in craftcms/cms KEVCVSS 4.0CRITICAL 9.3
  • TI-2025-16994 Potential RCE with a compromised security key in craft/cms KEVCVSS 3.1HIGH 8.1
  • TI-2025-24595 Craft CMS stores user-provided content in session files KEVCVSS 4.0MEDIUM 6.9
  • TI-2023-22284 Craft CMS Remote Code Execution vulnerability CVSS 3.1CRITICAL 10.0
  • TI-2024-25171 Craft CMS up to v3.7.31 was discovered to contain a SQL injection vulnerability via the GraphQL API endpoint. CVSS 3.1CRITICAL 9.8
See all 96 →

Sources