Read the docs
TI-2025-42131 Aliases CVE-2025-68613GHSA-v98v-ff95-f3cp

n8n Vulnerable to Remote Code Execution via Expression Injection

Priority CRITICAL 100Exploited in the wildCWE-913Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.

Summary

n8n is an open source workflow automation platform. Versions starting with 0.211.0 and prior to 1.120.4, 1.121.1, and 1.122.0 contain a critical Remote Code Execution (RCE) vulnerability in their workflow expression evaluation system. Under certain conditions, expressions supplied by authenticated users during workflow configuration may be evaluated in an execution context that is not sufficiently isolated from the underlying runtime. An authenticated attacker could abuse this behavior to execute arbitrary code with the privileges of the n8n process. Successful exploitation may lead to full compromise of the affected instance, including unauthorized access to sensitive data, modification of workflows, and execution of system-level operations. This issue has been fixed in versions 1.120.4, 1.121.1, and 1.122.0. Users are strongly advised to upgrade to a patched version, which introduces additional safeguards to restrict expression evaluation. If upgrading is not immediately possible, administrators should consider the following temporary mitigations: Limit workflow creation and editing permissions to fully trusted users only; and/or deploy n8n in a hardened environment with restricted operating system privileges and network access to reduce the impact of potential exploitation. These workarounds do not fully eliminate the risk and should only be used as short-term measures.

Why it matters now

Exploitation Active In CISA KEV since 2026-03-11CISA due date 2026-03-25
EPSS 0.98994 99th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed n8n (n8n-io): 1.120.4n8n (npm): 1.120.4, 1.121.1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Active
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
n8nn8n0.211.0 to before 1.120.4; = 1.121.01.120.4Patch availableCNA
—n8n (npm)0.211.0 to before 1.120.41.120.4Patch availableGHSA-v98v-ff95-f3cp
—n8n (npm)1.121.0 to before 1.121.11.121.1Patch availableGHSA-v98v-ff95-f3cp
  • n8n Vendorn8n Affected 0.211.0 to before 1.120.4; = 1.121.0 Fixed in 1.120.4 Patch available CNA
  • n8n (npm) Vendor— Affected 0.211.0 to before 1.120.4 Fixed in 1.120.4 Patch available GHSA-v98v-ff95-f3cp
  • n8n (npm) Vendor— Affected 1.121.0 to before 1.121.1 Fixed in 1.121.1 Patch available GHSA-v98v-ff95-f3cp

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:n8n:n8n:*:*:*:*:*:node.js:*:*0.211.0 to before 1.120.4Vulnerablen8n
cpe:2.3:a:n8n:n8n:1.121.0:*:*:*:*:node.js:*:*1.121.0Vulnerablen8n
  • cpe:2.3:a:n8n:n8n:*:*:*:*:*:node.js:*:* Versions 0.211.0 to before 1.120.4 Vulnerable ·n8n
  • cpe:2.3:a:n8n:n8n:1.121.0:*:*:*:*:node.js:*:* Versions 1.121.0 Vulnerable ·n8n

Remediation

  • Fix · CNA n8n (n8n-io) Fixed in 1.120.4
  • Fix · GHSA-v98v-ff95-f3cp n8n (npm) Fixed in 1.120.4 Advisory →
  • Fix · GHSA-v98v-ff95-f3cp n8n (npm) Fixed in 1.121.1 Advisory →

Timeline

  1. 2026-03-11 Added to CISA KEV
  2. 2026-10-02 Threatist record created from CVE-2025-68613
  3. 2026-10-03 Alias added: GHSA-v98v-ff95-f3cp

References

  • TI-2026-17560 n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling CVSS 3.1CRITICAL 10.0
  • TI-2026-01167 Authenticated users can bypass the Expression sandbox mechanism to achieve full remote… CVSS 3.1CRITICAL 9.9
  • TI-2026-00644 Sandbox escape in n8n Python task runner allows for arbitrary code execution on the underlying host. CVSS 3.1CRITICAL 9.9
  • TI-2025-35293 An arbitrary file upload vulnerability in the Chat Trigger component of N8N v1.95.3… CVSS 3.1HIGH 8.8
  • TI-2023-12275 The n8n package 0.218.0 for Node.js allows Escalation of Privileges. CVSS 3.1HIGH 8.8
  • TI-2023-12276 The n8n package 0.218.0 for Node.js allows Information Disclosure. CVSS 3.1HIGH 7.5
See all 178 →

Sources