Authenticated users can bypass the Expression sandbox mechanism to achieve full remote…
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-95.
Summary
n8n contains a critical Remote Code Execution (RCE) vulnerability in its workflow Expression evaluation system. Expressions supplied by authenticated users during workflow configuration may be evaluated in an execution context that is not sufficiently isolated from the underlying runtime. An authenticated attacker could abuse this behavior to execute arbitrary code with the privileges of the n8n process. Successful exploitation may lead to full compromise of the affected instance, including unauthorized access to sensitive data, modification of workflows, and execution of system-level operations.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | n8n | before 1.123.17; 2.0.0 to before 2.4.5; 2.5.0 to before 2.5.1 | 1.123.17, 2.4.5, 2.5.1 | Patch available | CNA |
| — | n8n (npm) | before 1.123.17 | 1.123.17 | Patch available | GHSA-5xrp-6693-jjx9 |
| — | n8n (npm) | 2.0.0 to before 2.4.5 | 2.4.5 | Patch available | GHSA-5xrp-6693-jjx9 |
| — | n8n (npm) | 2.5.0 to before 2.5.1 | 2.5.1 | Patch available | GHSA-5xrp-6693-jjx9 |
- n8n Vendor— Affected before 1.123.17; 2.0.0 to before 2.4.5; 2.5.0 to before 2.5.1 Fixed in 1.123.17, 2.4.5, 2.5.1 Patch available CNA
- n8n (npm) Vendor— Affected before 1.123.17 Fixed in 1.123.17 Patch available GHSA-5xrp-6693-jjx9
- n8n (npm) Vendor— Affected 2.0.0 to before 2.4.5 Fixed in 2.4.5 Patch available GHSA-5xrp-6693-jjx9
- n8n (npm) Vendor— Affected 2.5.0 to before 2.5.1 Fixed in 2.5.1 Patch available GHSA-5xrp-6693-jjx9
Remediation
- Fix · CNA n8n Fixed in 1.123.17, 2.4.5, 2.5.1
- Fix · GHSA-5xrp-6693-jjx9 n8n (npm) Fixed in 1.123.17 Advisory →
- Fix · GHSA-5xrp-6693-jjx9 n8n (npm) Fixed in 2.4.5 Advisory →
- Fix · GHSA-5xrp-6693-jjx9 n8n (npm) Fixed in 2.5.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-1470
- 2026-10-03 Alias added: GHSA-5xrp-6693-jjx9
References
More N8n vulnerabilities
- TI-2025-42131 n8n Vulnerable to Remote Code Execution via Expression Injection KEVCVSS 3.1CRITICAL 10.0
- TI-2026-17560 n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling CVSS 3.1CRITICAL 10.0
- TI-2026-00644 Sandbox escape in n8n Python task runner allows for arbitrary code execution on the underlying host. CVSS 3.1CRITICAL 9.9
- TI-2025-35293 An arbitrary file upload vulnerability in the Chat Trigger component of N8N v1.95.3… CVSS 3.1HIGH 8.8
- TI-2023-12275 The n8n package 0.218.0 for Node.js allows Escalation of Privileges. CVSS 3.1HIGH 8.8
- TI-2023-12276 The n8n package 0.218.0 for Node.js allows Information Disclosure. CVSS 3.1HIGH 7.5
Sources
- CVE-2026-1470 · CVE Program
- CVE-2026-1470 · NVD
- FIRST EPSS
- GHSA-5xrp-6693-jjx9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences