Path traversal in Octopus Server
Priority LOW 27CWE-22Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- High
- Attack requirements
- Present
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA.
Summary
In affected version of Octopus Deploy it was possible to remove files and/or contents of files on the host using an API endpoint. The field lacked validation which could potentially result in ways to circumvent expected workflows.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00378 31st percentileScored 2026-11-07
Fix Fixed Octopus Server (Octopus Deploy): 2025.3.14715, 2025.4.10359
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Octopus Deploy | Octopus Server | 2023.0.0 to before 2025.3.14715; 2025.4.0 to before 2025.4.10359 | 2025.3.14715, 2025.4.10359 | Patch available | CNA |
- Octopus Server VendorOctopus Deploy Affected 2023.0.0 to before 2025.3.14715; 2025.4.0 to before 2025.4.10359 Fixed in 2025.3.14715, 2025.4.10359 Patch available CNA
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:octopus:octopus_server:*:*:*:*:*:*:*:* | 2023.1.4189 to before 2025.3.14715 | Vulnerable | Octopus Deploy |
| cpe:2.3:o:linux:linux_kernel:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Linux |
| cpe:2.3:o:microsoft:windows:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Microsoft |
- cpe:2.3:a:octopus:octopus_server:*:*:*:*:*:*:*:* Versions 2023.1.4189 to before 2025.3.14715 Vulnerable ·Octopus Deploy
- cpe:2.3:o:linux:linux_kernel:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Linux
- cpe:2.3:o:microsoft:windows:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Microsoft
Remediation
- Fix · CNA Octopus Server (Octopus Deploy) Fixed in 2025.3.14715, 2025.4.10359
Timeline
- 2026-10-02 Threatist record created from CVE-2026-0704
- 2026-10-03 Alias added: GHSA-mmcc-ppg6-c7j2
References
More Octopus Deploy Octopus Server vulnerabilities
- TI-2018-13353 In Octopus Deploy 2018.8.0 through 2018.9.x before 2018.9.1, an authenticated user with… CVSS 3.0HIGH 8.8
- TI-2022-02375 Improper authentication in Octopus Server CVSS 3.1CRITICAL 9.8
- TI-2022-02579 Insufficient session expiration in Octopus Server CVSS 3.1CRITICAL 9.1
- TI-2018-08066 In Octopus Deploy 2018.4.4 through 2018.5.1, Octopus variables that are sourced from the… CVSS 3.0CRITICAL 9.8
- TI-2022-02575 In affected versions of Octopus Deploy it is possible to bypass rate limiting on login using null bytes. CVSS 3.1CRITICAL 9.8
- TI-2022-03678 In affected versions of Octopus Deploy it is possible for a user to introduce code via offline package creation CVSS 3.1HIGH 8.8
Sources
- CVE-2026-0704 · CVE Program
- CVE-2026-0704 · NVD
- FIRST EPSS
- GHSA-mmcc-ppg6-c7j2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences