Membership Plugin – Restrict Content <= 3.2.20 - Unauthenticated Privilege Escalation via 'rcp_level'
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-862.
Summary
The Membership Plugin – Restrict Content plugin for WordPress is vulnerable to Privilege Escalation in all versions up to, and including, 3.2.20. This is due to the `rcp_setup_registration_init()` function accepting any membership level ID via the `rcp_level` POST parameter without validating that the level is active or that payment is required. Combined with the `add_user_role()` method which assigns the WordPress role configured on the membership level without status checks, this makes it possible for unauthenticated attackers to register with any membership level, including inactive levels that grant privileged WordPress roles such as Administrator, or paid levels that charge a sign-up fee. The vulnerability was partially patched in version 3.2.18.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| stellarwp | Membership Plugin – Restrict Content | up to 3.2.20 | — | No fix listed | CNA |
- Membership Plugin – Restrict Content Vendorstellarwp Affected up to 3.2.20 Fixed in — No fix listed CNA
CPE names Threatist (inferred) · 1
Inferred from how NVD named this product before; not given by a source.
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:liquidweb:restrict_content:*:*:*:*:*:*:*:* | — | — | Liquid Web |
- cpe:2.3:a:liquidweb:restrict_content:*:*:*:*:*:*:*:* Versions — — ·Liquid Web
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2026-1321
- 2026-10-03 Alias added: GHSA-j7r4-m35r-qffp
References
Other 7
- https://www.wordfence.com/threat-intel/vulnerabilities/id/abfaa4a6-92b0-4233-b08d-e668090d3fc2?source=cve
- https://plugins.trac.wordpress.org/browser/restrict-content/tags/3.2.15/core/includes/registration-functions.php#L1191
- https://plugins.trac.wordpress.org/browser/restrict-content/tags/3.2.15/core/includes/registration-functions.php#L1203
- https://plugins.trac.wordpress.org/browser/restrict-content/tags/3.2.15/core/includes/class-rcp-registration.php#L107
- https://plugins.trac.wordpress.org/browser/restrict-content/tags/3.2.15/core/includes/memberships/class-rcp-membership.php#L1939
- https://plugins.trac.wordpress.org/changeset/3447187/
- https://plugins.trac.wordpress.org/changeset/3460177/
More stellarwp vulnerabilities
- TI-2024-05498 Deserialization of untrusted data in stellarwp GiveWP – Donation Plugin and Fundraising… CVSS 3.1CRITICAL 10.0
- TI-2023-02655 BookIt <= 2.3.7 - Authentication Bypass CVSS 3.1CRITICAL 9.8
- TI-2024-07671 The Events Calendar <= 6.6.4 - Unauthenticated SQL Injection CVSS 3.1CRITICAL 9.8
- TI-2024-03888 The Events Calendar < 6.4.0.1 - Reflected XSS CVSS 3.1CRITICAL 9.1
- TI-2024-07745 GiveWP – Donation Plugin and Fundraising Platform <= 3.16.1 - Unauthenticated PHP Object Injection CVSS 3.1CRITICAL 9.8
- TI-2024-04952 The Events Calendar < 6.8.2.1 - Unauthenticated Password Protected Event Disclosure CVSS 3.1MEDIUM 5.3
Sources
- CVE-2026-1321 · CVE Program
- CVE-2026-1321 · NVD
- FIRST EPSS
- GHSA-j7r4-m35r-qffp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences