Read the docs
TI-2026-01252 Aliases CVE-2026-1563GHSA-pcfw-jm9h-vg4m

Cross-site scripting in Pegasystems Pega Infinity

Priority LOW 22CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
Passive
Attack complexity
Low
Attack requirements
None
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-79.

Summary

Pega Platform versions 8.1.0 through 25.1.2 are affected by an Reflected Cross-site scripting (XSS) vulnerability in a user interface component. Requires a high privileged user with a developer role.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00242 15th percentileScored 2026-11-07
Fix Fixed Pega Infinity (Pegasystems): Infinity 25.1.2

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
PegasystemsPega Infinity8.1.0 to before Infinity 25.1.2Infinity 25.1.2Patch availableCNA
  • Pega Infinity VendorPegasystems Affected 8.1.0 to before Infinity 25.1.2 Fixed in Infinity 25.1.2 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:pega:pega_platform:*:*:*:*:*:*:*:*8.1 to before 24.2.4; 25.1.0 to before 25.1.3VulnerablePegasystems
  • cpe:2.3:a:pega:pega_platform:*:*:*:*:*:*:*:* Versions 8.1 to before 24.2.4; 25.1.0 to before 25.1.3 Vulnerable ·Pegasystems

Remediation

  • Fix · CNA Pega Infinity (Pegasystems) Fixed in Infinity 25.1.2

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    Pegasystems Pega Infinity Infinity 25.1.2

    2 records Highest priority Priority LOW 2 LOW

    Other records, highest priority first

    • TI-2026-01251 Cross-site scripting in Pegasystems Pega InfinityPriority LOW 21

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-1563
  2. 2026-10-03 Alias added: GHSA-pcfw-jm9h-vg4m

References

  • TI-2023-15393 Pega platform clients who are using versions 6.1 through 7.3.1 may be utilizing default credentials CVSS 3.1CRITICAL 9.8
  • TI-2020-12137 pyActivity in Pega Platform 8.4.0.237 has a security misconfiguration that leads to an… CVSS 3.1CRITICAL 9.8
  • TI-2023-12673 Pega platform clients who are using versions 7.4 through 8.8.x and have upgraded from a… CVSS 3.1CRITICAL 9.8
  • TI-2020-07035 Pega Platform before version 8.2.6 is affected by a Reflected Cross-Site Scripting… CVSS 3.1HIGH 8.8
  • TI-2019-12322 PEGA Platform 8.3.0 is vulnerable to a direct… CVSS 3.1HIGH 8.1
  • TI-2025-01892 Pega Platform versions 8.4.3 to Infinity 24.2.1 are affected by an XSS issue with Mashup CVSS 3.1HIGH 8.1
See all 28 →

Sources