SQL Injection in Contact Activity API Sorting
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-89.
Summary
SummaryThis advisory addresses a SQL injection vulnerability in the API endpoint used for retrieving contact activities. A vulnerability exists in the query construction for the Contact Activity timeline where the parameter responsible for determining the sort direction was not strictly validated against an allowlist, potentially allowing authenticated users to inject arbitrary SQL commands via the API. MitigationPlease update to 4.4.19, 5.2.10, 6.0.8, 7.0.1 or later. WorkaroundsNone. ReferencesIf you have any questions or comments about this advisory: Email us at [email protected]
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Mautic | Mautic | >= 2.10.0 to before < 4.4.19 <5.2.10 <6.0.8 <7.0.1 | < 4.4.19 <5.2.10 <6.0.8 <7.0.1 | Patch available | CNA |
| — | mautic/core (Packagist) | 2.10.0 to before 5.2.10 | 5.2.10 | Patch available | GHSA-r5j5-q42h-fc93 |
| — | mautic/core (Packagist) | 6.0.0-alpha to before 6.0.8 | 6.0.8 | Patch available | GHSA-r5j5-q42h-fc93 |
| — | mautic/core (Packagist) | 7.0.0-alpha to before 7.0.1 | 7.0.1 | Patch available | GHSA-r5j5-q42h-fc93 |
- Mautic VendorMautic Affected >= 2.10.0 to before < 4.4.19 <5.2.10 <6.0.8 <7.0.1 Fixed in < 4.4.19 <5.2.10 <6.0.8 <7.0.1 Patch available CNA
- mautic/core (Packagist) Vendor— Affected 2.10.0 to before 5.2.10 Fixed in 5.2.10 Patch available GHSA-r5j5-q42h-fc93
- mautic/core (Packagist) Vendor— Affected 6.0.0-alpha to before 6.0.8 Fixed in 6.0.8 Patch available GHSA-r5j5-q42h-fc93
- mautic/core (Packagist) Vendor— Affected 7.0.0-alpha to before 7.0.1 Fixed in 7.0.1 Patch available GHSA-r5j5-q42h-fc93
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:acquia:mautic:*:*:*:*:*:*:*:* | 2.10.0 to before 4.4.19; 5.0.0 to before 5.2.10; 6.0.0 to before 6.0.8; 7.0.0 to before 7.0.1 | Vulnerable | Acquia |
- cpe:2.3:a:acquia:mautic:*:*:*:*:*:*:*:* Versions 2.10.0 to before 4.4.19; 5.0.0 to before 5.2.10; 6.0.0 to before 6.0.8; 7.0.0 to before 7.0.1 Vulnerable ·Acquia
Remediation
- Fix · CNA Mautic (Mautic) Fixed in < 4.4.19 <5.2.10 <6.0.8 <7.0.1
- Fix · GHSA-r5j5-q42h-fc93 mautic/core (Packagist) Fixed in 5.2.10 Advisory →
- Fix · GHSA-r5j5-q42h-fc93 mautic/core (Packagist) Fixed in 6.0.8 Advisory →
- Fix · GHSA-r5j5-q42h-fc93 mautic/core (Packagist) Fixed in 7.0.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-3105
- 2026-10-03 Alias added: GHSA-r5j5-q42h-fc93
References
Advisory 2
More Mautic vulnerabilities
- TI-2022-09344 Cross-site scripting in Mautic CVSS 3.1CRITICAL 9.6
- TI-2024-02543 Predictable Page Indexing Might Lead to Sensitive Data Exposure in Mautic CVSS 3.1MEDIUM 5.3
- TI-2024-02544 Improper Access Control Issues Lead to Sensitive Data Exposure in Mautic CVSS 3.1MEDIUM 5.4
- TI-2024-03218 Improper Access Control Leads to Server-Side Request Forgery in Mautic CVSS 3.1MEDIUM 5.0
- TI-2024-31435 Remote Code Execution & File Deletion in Asset Uploads CVSS 3.1CRITICAL 9.9
- TI-2018-05847 Mautic before 2.13.0 allows CSV injection. CVSS 3.0CRITICAL 9.8
Sources
- CVE-2026-3105 · CVE Program
- CVE-2026-3105 · NVD
- FIRST EPSS
- GHSA-r5j5-q42h-fc93 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences