Improper authorization in Octopus Server
Priority LOW 11CWE-285Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-285.
Summary
In affected versions of Octopus Server it was possible for a low privileged user to manipulate an API request to change the signing key expiration and revocation time frames via an API endpoint that had incorrect permission validation. It was not possible to expose the signing keys using this vulnerability.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00162 5th percentileScored 2026-11-07
Fix Fixed Octopus Server (Octopus Deploy): 2025.3.14731, 2025.4.10359, 2026.1.5571
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Octopus Deploy | Octopus Server | 2023.0.0 to before 2025.3.14731; 2025.4.0 to before 2025.4.10359; 2026.1.0 to before 2026.1.5571 | 2025.3.14731, 2025.4.10359, 2026.1.5571 | Patch available | CNA |
- Octopus Server VendorOctopus Deploy Affected 2023.0.0 to before 2025.3.14731; 2025.4.0 to before 2025.4.10359; 2026.1.0 to before 2026.1.5571 Fixed in 2025.3.14731, 2025.4.10359, 2026.1.5571 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:octopus:octopus_server:*:*:*:*:*:*:*:* | before 2025.3.14731; 2025.4.51 to before 2025.4.10359; 2026.1.675 to before 2026.1.5571 | Vulnerable | Octopus Deploy |
- cpe:2.3:a:octopus:octopus_server:*:*:*:*:*:*:*:* Versions before 2025.3.14731; 2025.4.51 to before 2025.4.10359; 2026.1.675 to before 2026.1.5571 Vulnerable ·Octopus Deploy
Remediation
- Fix · CNA Octopus Server (Octopus Deploy) Fixed in 2025.3.14731, 2025.4.10359, 2026.1.5571
Timeline
- 2026-10-02 Threatist record created from CVE-2026-3237
- 2026-10-03 Alias added: GHSA-q8w5-c2m8-wxrx
References
More Octopus Deploy Octopus Server vulnerabilities
- TI-2018-13353 In Octopus Deploy 2018.8.0 through 2018.9.x before 2018.9.1, an authenticated user with… CVSS 3.0HIGH 8.8
- TI-2022-02375 Improper authentication in Octopus Server CVSS 3.1CRITICAL 9.8
- TI-2022-02579 Insufficient session expiration in Octopus Server CVSS 3.1CRITICAL 9.1
- TI-2018-08066 In Octopus Deploy 2018.4.4 through 2018.5.1, Octopus variables that are sourced from the… CVSS 3.0CRITICAL 9.8
- TI-2022-02575 In affected versions of Octopus Deploy it is possible to bypass rate limiting on login using null bytes. CVSS 3.1CRITICAL 9.8
- TI-2022-03678 In affected versions of Octopus Deploy it is possible for a user to introduce code via offline package creation CVSS 3.1HIGH 8.8
Sources
- CVE-2026-3237 · CVE Program
- CVE-2026-3237 · NVD
- FIRST EPSS
- GHSA-q8w5-c2m8-wxrx · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences