Read the docs
TI-2026-04434 Aliases CVE-2026-5079GHSA-72gw-mp4g-v24j

multer vulnerable to Denial of Service via deeply nested field names

Priority LOW 39CWE-400Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · High
Fix status
Partial Red Hat: 4 fixed, 1 without a fix

Attack profile from CVSS 3.1 · CNA. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-400.

Summary

Impact: multer versions 1.0.0 through 2.1.1 and 3.0.0-alpha.1 are vulnerable to a Denial of Service via deeply nested field names in multipart form data. The append-field dependency parses bracket notation in field names with no limit on nesting depth, allowing an attacker to force allocation of deeply nested object structures that consume CPU and memory. A single HTTP request with a crafted multipart body is sufficient to exploit this. Patches: Users should upgrade to multer 2.2.0 (2.x line) or 3.0.0-alpha.2 (3.x prerelease) and configure the new limits.fieldNestingDepth option to the minimum depth their application requires. Workarounds: Set limits.fields to a reasonable value to reduce the number of fields an attacker can send per request. This does not fully mitigate the issue but limits the impact.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00279 20th percentileScored 2026-11-07
Fix Partial multer (multer): 2.2.0, 3.0.0-alpha.2multer (npm): 2.2.0, 3.0.0-alpha.2Red Hat: 5 advisoriesRed Hat: 4 fixed, 1 without a fix

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
expressjsmulter1.0.0 to before 2.2.0; 3.0.0-alpha.1 to before 3.0.0-alpha.22.2.0, 3.0.0-alpha.2Patch availableCNA
—multer (npm)1.0.0 to before 2.2.02.2.0Patch availableGHSA-72gw-mp4g-v24j
—multer (npm)3.0.0-alpha.1 to before 3.0.0-alpha.23.0.0-alpha.2Patch availableGHSA-72gw-mp4g-v24j
  • multer Vendorexpressjs Affected 1.0.0 to before 2.2.0; 3.0.0-alpha.1 to before 3.0.0-alpha.2 Fixed in 2.2.0, 3.0.0-alpha.2 Patch available CNA
  • multer (npm) Vendor— Affected 1.0.0 to before 2.2.0 Fixed in 2.2.0 Patch available GHSA-72gw-mp4g-v24j
  • multer (npm) Vendor— Affected 3.0.0-alpha.1 to before 3.0.0-alpha.2 Fixed in 3.0.0-alpha.2 Patch available GHSA-72gw-mp4g-v24j

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:expressjs:multer:*:*:*:*:*:node.js:*:*1.0.0 to before 2.2.0Vulnerableexpressjs
cpe:2.3:a:expressjs:multer:3.0.0:alpha1:*:*:*:node.js:*:*3.0.0 alpha1Vulnerableexpressjs
  • cpe:2.3:a:expressjs:multer:*:*:*:*:*:node.js:*:* Versions 1.0.0 to before 2.2.0 Vulnerable ·expressjs
  • cpe:2.3:a:expressjs:multer:3.0.0:alpha1:*:*:*:node.js:*:* Versions 3.0.0 alpha1 Vulnerable ·expressjs

Remediation

  • Fix · CNA multer (multer) Fixed in 2.2.0, 3.0.0-alpha.2
  • Fix · GHSA-72gw-mp4g-v24j multer (npm) Fixed in 2.2.0 Advisory →
  • Fix · GHSA-72gw-mp4g-v24j multer (npm) Fixed in 3.0.0-alpha.2 Advisory →

Red Hat 5 advisories

  • RHSA-2026:66003 Released 2026-09-09 · Red Hat rating Important
    Ansible automation portal Red Hat Enterprise Linux Images
    • Red Hat Ansible Automation Platform 2.2 registry.redhat.io/ansible-automation-platform/bootc-automation-portal-rhel9
  • RHSA-2026:65118 Released 2026-09-08 · Red Hat rating Important
    Ansible plug-ins for Red Hat Developer Hub Product Release Update
    • Red Hat Ansible Automation Platform 2.1 registry.redhat.io/ansible-automation-platform/automation-portal
  • RHSA-2026:52768 Released 2026-08-10 · Red Hat rating Important
    Red Hat Developer Hub 1.9.8 release.
    • Red Hat Developer Hub 1.9 registry.redhat.io/rhdh/rhdh-hub-rhel9
Show 2 more Red Hat advisories
  • RHSA-2026:49642 Released 2026-08-03 · Red Hat rating Important
    Red Hat Developer Hub 1.10.3 release.
    • Red Hat Developer Hub 1.10 registry.redhat.io/rhdh/rhdh-hub-rhel9, registry.redhat.io/rhdh/rhdh-rhel9-operator
  • RHSA-2026:48126 Released 2026-07-29 · Red Hat rating Important
    Red Hat Developer Hub 1.10.3 Plugin Catalog GA plugins release.
    • Red Hat Developer Hub 1.10 registry.redhat.io/rhdh/red-hat-developer-hub-backstage-plugin-lightspeed, registry.redhat.io/rhdh/red-hat-developer-hub-backstage-plugin-lightspeed-backend, registry.redhat.io/rhdh/red-hat-developer-hub-backstage-plugin-orchestrator +4

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    multer 2.2.0, 3.0.0-alpha.2

    2 records Highest priority Priority LOW 2 LOW

    Other records, highest priority first

    • TI-2026-04396 multer vulnerable to Denial of Service via incomplete cleanup of aborted uploadsPriority LOW 39

Vendor assessments

Red Hat

Red Hat rating: Important. Red Hat's page for this CVE →

ProductStatusPlan or fix
Logging Subsystem for Red Hat OpenShiftAffectedNo fix yet
Red Hat Ansible Automation Platform 2.1Fixed RHSA-2026:65118
Red Hat Ansible Automation Platform 2.2Fixed RHSA-2026:66003
Red Hat Developer Hub 1.10Fixed RHSA-2026:48126, RHSA-2026:49642
Red Hat Developer Hub 1.9Fixed RHSA-2026:52768
Not affected: 7 products
  • Red Hat Developer Hub 1.10
  • Red Hat Developer Hub 1.9
  • Red Hat Enterprise Linux 10
  • Red Hat Enterprise Linux 7
  • Red Hat Enterprise Linux 8
  • Red Hat Enterprise Linux 9
  • Red Hat Trusted Profile Analyzer

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-5079
  2. 2026-10-03 Alias added: GHSA-72gw-mp4g-v24j

References

  • TI-2026-03033 Multer vulnerable to Denial of Service via uncontrolled recursion CVSS 4.0HIGH 8.7
  • TI-2026-02853 Multer vulnerable to Denial of Service via incomplete cleanup CVSS 4.0HIGH 8.7
  • TI-2026-01995 Multer vulnerable to Denial of Service via resource exhaustion CVSS 4.0HIGH 8.7
  • TI-2026-56780 multer vulnerable to Denial of Service via oversized array index in field names CVSS 3.1HIGH 7.5
  • TI-2026-53831 multer vulnerable to Denial of Service via crafted multipart field names CVSS 3.1HIGH 7.5
  • TI-2026-53816 multer vulnerable to Denial of Service via file descriptor leak on aborted uploads CVSS 3.1HIGH 7.5
See all 8 →

Sources