Authorization bypass in GitHub Enterprise Server
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-639.
Summary
An authorization bypass vulnerability was identified in GitHub Enterprise Server that allowed an attacker with admin access on one repository to modify the secret scanning push protection delegated bypass reviewer list on another repository by manipulating the owner_id parameter in the request body. Authorization was verified against the repository in the URL, but the action was applied to a different repository specified in the request body. The impact is limited to assigning existing trusted users as bypass reviewers; it does not allow adding arbitrary external users. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.21 and was fixed in versions 3.14.25, 3.15.20, 3.16.16, 3.17.13, 3.18.7, 3.19.4 and 3.20.1. This vulnerability was reported via the GitHub Bug Bounty program.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GitHub | Enterprise Server | 3.14.0 – 3.14.24; 3.15.0 – 3.15.19; 3.16.0 – 3.16.15; 3.17.0 – 3.17.12; 3.18.0 – 3.18.6; 3.19.0 – 3.19.3; 3.20 – 3.20.0 | — | No fix listed | CNA |
- Enterprise Server VendorGitHub Affected 3.14.0 – 3.14.24; 3.15.0 – 3.15.19; 3.16.0 – 3.16.15; 3.17.0 – 3.17.12; 3.18.0 – 3.18.6; 3.19.0 – 3.19.3; 3.20 – 3.20.0 Fixed in — No fix listed CNA
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:github:enterprise_server:*:*:*:*:*:*:*:* | before 3.14.26; 3.15.0 to before 3.15.21; 3.16.0 to before 3.16.17; 3.17.0 to before 3.17.14; 3.18.0 to before 3.18.8; 3.19.0 to before 3.19.5 | Vulnerable | GitHub |
| cpe:2.3:a:github:enterprise_server:3.20.0:*:*:*:*:*:*:* | 3.20.0 | Vulnerable | GitHub |
- cpe:2.3:a:github:enterprise_server:*:*:*:*:*:*:*:* Versions before 3.14.26; 3.15.0 to before 3.15.21; 3.16.0 to before 3.16.17; 3.17.0 to before 3.17.14; 3.18.0 to before 3.18.8; 3.19.0 to before 3.19.5 Vulnerable ·GitHub
- cpe:2.3:a:github:enterprise_server:3.20.0:*:*:*:*:*:*:* Versions 3.20.0 Vulnerable ·GitHub
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2026-3307
- 2026-10-03 Alias added: GHSA-9mpg-26vj-7vx3
References
Advisory 7
- https://docs.github.com/en/[email protected]/admin/release-notes#3.14.25
- https://docs.github.com/en/[email protected]/admin/release-notes#3.15.20
- https://docs.github.com/en/[email protected]/admin/release-notes#3.16.16
- https://docs.github.com/en/[email protected]/admin/release-notes#3.17.13
- https://docs.github.com/en/[email protected]/admin/release-notes#3.18.7
- https://docs.github.com/en/[email protected]/admin/release-notes#3.19.4
- https://docs.github.com/en/[email protected]/admin/release-notes#3.20.1
More GitHub Enterprise Server vulnerabilities
- TI-2024-04632 An authentication bypass vulnerability was present in the GitHub Enterprise Server (GHES)… CVSS 4.0CRITICAL 10.0
- TI-2024-00181 Unsafe Reflection in Github Enterprise Server leading to Command Injection CVSS 3.1CRITICAL 9.8
- TI-2024-00466 Privilege Escalation by Code Injection in the Management Console in GitHub Enterprise Server CVSS 3.1HIGH 8.8
- TI-2026-03340 Remote code execution via git push option injection in GitHub Enterprise Server CVSS 4.0HIGH 8.7
- TI-2024-08804 Improper signature verification in GitHub Enterprise Server CVSS 4.0CRITICAL 9.5
- TI-2026-08177 Server-side request forgery in GitHub Enterprise Server CVSS 4.0CRITICAL 9.2
Sources
- CVE-2026-3307 · CVE Program
- CVE-2026-3307 · NVD
- FIRST EPSS
- GHSA-9mpg-26vj-7vx3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences