Missing authentication in GitHub Enterprise Server
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- No fix listed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-306.
Summary
An authentication bypass vulnerability was identified in GitHub Enterprise Server that allowed an unauthenticated attacker to create a local user account, bypassing the configured external identity provider. When external authentication was enabled, the signup endpoint did not properly enforce the authentication restriction, allowing account creation and session establishment without identity provider validation. The created account was limited to the default base permissions configured on the instance. Exploitation required network access to a GHES instance configured with an external authentication provider. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.21 and was fixed in versions 3.20.2, 3.19.6, 3.18.9, 3.17.15, and 3.16.18.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GitHub | Enterprise Server | 3.16.0 – 3.16.17; 3.17.0 – 3.17.14; 3.18.0 – 3.18.8; 3.19.0 – 3.19.5; 3.20.0 – 3.20.1 | — | No fix listed | CNA |
- Enterprise Server VendorGitHub Affected 3.16.0 – 3.16.17; 3.17.0 – 3.17.14; 3.18.0 – 3.18.8; 3.19.0 – 3.19.5; 3.20.0 – 3.20.1 Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:github:enterprise_server:*:*:*:*:*:*:*:* | before 3.16.18; 3.17.0 to before 3.17.15; 3.18.0 to before 3.18.9; 3.19.0 to before 3.19.6; 3.20.0 to before 3.20.2 | Vulnerable | GitHub |
- cpe:2.3:a:github:enterprise_server:*:*:*:*:*:*:*:* Versions before 3.16.18; 3.17.0 to before 3.17.15; 3.18.0 to before 3.18.9; 3.19.0 to before 3.19.6; 3.20.0 to before 3.20.2 Vulnerable ·GitHub
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2026-6736
- 2026-10-03 Alias added: GHSA-2gcr-p5w4-5hh8
References
Advisory 5
- https://docs.github.com/en/[email protected]/admin/release-notes#3.16.18
- https://docs.github.com/en/[email protected]/admin/release-notes#3.17.15
- https://docs.github.com/en/[email protected]/admin/release-notes#3.18.9
- https://docs.github.com/en/[email protected]/admin/release-notes#3.19.6
- https://docs.github.com/en/[email protected]/admin/release-notes#3.20.2
More GitHub Enterprise Server vulnerabilities
- TI-2024-04632 An authentication bypass vulnerability was present in the GitHub Enterprise Server (GHES)… CVSS 4.0CRITICAL 10.0
- TI-2024-00181 Unsafe Reflection in Github Enterprise Server leading to Command Injection CVSS 3.1CRITICAL 9.8
- TI-2024-00466 Privilege Escalation by Code Injection in the Management Console in GitHub Enterprise Server CVSS 3.1HIGH 8.8
- TI-2026-03340 Remote code execution via git push option injection in GitHub Enterprise Server CVSS 4.0HIGH 8.7
- TI-2024-08804 Improper signature verification in GitHub Enterprise Server CVSS 4.0CRITICAL 9.5
- TI-2026-08177 Server-side request forgery in GitHub Enterprise Server CVSS 4.0CRITICAL 9.2
Sources
- CVE-2026-6736 · CVE Program
- CVE-2026-6736 · NVD
- FIRST EPSS
- GHSA-2gcr-p5w4-5hh8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences