Denial of service vulnerability in GitHub Enterprise Server allowed service disruption via unauthenticated API endpoint
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- No fix listed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-770.
Summary
A denial of service vulnerability was identified in GitHub Enterprise Server that allowed an unauthenticated attacker to cause service disruption by sending crafted requests with deeply nested JSON payloads to an unauthenticated API endpoint. The endpoint parsed user-controlled JSON request bodies without size or depth limits, causing excessive CPU and memory consumption. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.21 and was fixed in versions 3.20.2, 3.19.6, 3.18.9, 3.17.15, and 3.16.18. This vulnerability was reported via the GitHub Bug Bounty program.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GitHub | Enterprise Server | 3.16.0 – 3.16.17; 3.17.0 – 3.17.14; 3.18.0 – 3.18.8; 3.19.0 – 3.19.5; 3.20.0 – 3.20.1 | — | No fix listed | CNA |
- Enterprise Server VendorGitHub Affected 3.16.0 – 3.16.17; 3.17.0 – 3.17.14; 3.18.0 – 3.18.8; 3.19.0 – 3.19.5; 3.20.0 – 3.20.1 Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:github:enterprise_server:*:*:*:*:*:*:*:* | before 3.16.18; 3.17.0 to before 3.17.15; 3.18.0 to before 3.18.9; 3.19.0 to before 3.19.6; 3.20.0 to before 3.20.2 | Vulnerable | GitHub |
- cpe:2.3:a:github:enterprise_server:*:*:*:*:*:*:*:* Versions before 3.16.18; 3.17.0 to before 3.17.15; 3.18.0 to before 3.18.9; 3.19.0 to before 3.19.6; 3.20.0 to before 3.20.2 Vulnerable ·GitHub
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2026-7541
- 2026-10-03 Alias added: GHSA-3738-jvgh-jh3h
- 2026-10-11 EPSS moved to the 50th–90th percentile
- 2026-10-25 EPSS moved to the below the 50th percentile
References
Advisory 5
- https://docs.github.com/en/[email protected]/admin/release-notes#3.16.18
- https://docs.github.com/en/[email protected]/admin/release-notes#3.17.15
- https://docs.github.com/en/[email protected]/admin/release-notes#3.18.9
- https://docs.github.com/en/[email protected]/admin/release-notes#3.19.6
- https://docs.github.com/en/[email protected]/admin/release-notes#3.20.2
More GitHub Enterprise Server vulnerabilities
- TI-2024-04632 An authentication bypass vulnerability was present in the GitHub Enterprise Server (GHES)… CVSS 4.0CRITICAL 10.0
- TI-2024-00181 Unsafe Reflection in Github Enterprise Server leading to Command Injection CVSS 3.1CRITICAL 9.8
- TI-2024-00466 Privilege Escalation by Code Injection in the Management Console in GitHub Enterprise Server CVSS 3.1HIGH 8.8
- TI-2026-03340 Remote code execution via git push option injection in GitHub Enterprise Server CVSS 4.0HIGH 8.7
- TI-2024-08804 Improper signature verification in GitHub Enterprise Server CVSS 4.0CRITICAL 9.5
- TI-2026-08177 Server-side request forgery in GitHub Enterprise Server CVSS 4.0CRITICAL 9.2
Sources
- CVE-2026-7541 · CVE Program
- CVE-2026-7541 · NVD
- FIRST EPSS
- GHSA-3738-jvgh-jh3h · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences