Read the docs
TI-2026-06653 Aliases CVE-2026-7567GHSA-4v98-7r2c-mxg7

Temporary Login <= 1.0.0 - Authentication Bypass to Account Takeover

Priority MEDIUM 61CWE-288Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
High · High · High
Fix status
No fix listed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-288.

Summary

The Temporary Login plugin for WordPress is vulnerable to Authentication Bypass in versions up to and including 1.0.0. This is due to improper input validation in the maybe_login_temporary_user() function, which fails to verify that the 'temp-login-token' GET parameter is a scalar string before processing it. When the parameter is supplied as an array, PHP's empty() check is bypassed and sanitize_key() returns an empty string, which is then passed as the meta_value to get_users(). WordPress ignores an empty meta_value and returns all users matching the meta_key '_temporary_login_token', allowing authentication without a valid token. This makes it possible for unauthenticated attackers to authenticate as any active temporary login user by sending a single crafted GET request.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.09246 95th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ElementorTemporary Loginup to 1.0.0—No fix listedCNA
  • Temporary Login VendorElementor Affected up to 1.0.0 Fixed in — No fix listed CNA

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-7567
  2. 2026-10-03 Alias added: GHSA-4v98-7r2c-mxg7
  3. 2026-10-25 EPSS moved to the 95th–99th percentile

References

  • TI-2022-01211 Elementor Website Builder 3.6.0 - 3.6.2 - Missing Authorization to Remote Code Execution CVSS 3.1HIGH 8.8
  • TI-2023-00313 Elementor Website Builder < 3.12.2 - Admin+ SQLi CVSS 3.1HIGH 7.2
  • TI-2023-02927 Elementor Pro <= 3.11.6 - Authenticated(Subscriber+) Privilege Escalation via update_page_option CVSS 3.1HIGH 8.8
  • TI-2020-10317 An issue was discovered in the Elementor Pro plugin before 2.9.4 for WordPress, as… CVSS 3.1CRITICAL 9.9
  • TI-2023-25675 WordPress Elementor plugin <= 3.16.4 - Auth. Arbitrary Attachment Read vulnerability CVSS 3.1CRITICAL 9.8
  • TI-2023-26607 WordPress Elementor plugin 3.3.0-3.18.1 - Arbitrary File Upload vulnerability CVSS 3.1CRITICAL 9.9
See all 82 →

Sources