Elementor Website Builder < 3.12.2 - Admin+ SQLi
Priority HIGH 67Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The Elementor Website Builder WordPress plugin before 3.12.2 does not properly sanitize and escape the Replace URL parameter in the Tools module before using it in a SQL statement, leading to a SQL injection exploitable by users with the Administrator role.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.19695 97th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Elementor Website Builder (Unknown): 3.12.2
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Elementor Website Builder | before 3.12.2 | 3.12.2 | Patch available | CNA |
- Elementor Website Builder VendorUnknown Affected before 3.12.2 Fixed in 3.12.2 Patch available CNA
Remediation
- Fix · CNA Elementor Website Builder (Unknown) Fixed in 3.12.2
Timeline
- 2026-10-02 Threatist record created from CVE-2023-0329
- 2026-10-03 Alias added: GHSA-vfrh-jg7v-x9p3
References
More Elementor Website Builder vulnerabilities
- TI-2022-01211 Elementor Website Builder 3.6.0 - 3.6.2 - Missing Authorization to Remote Code Execution CVSS 3.1HIGH 8.8
- TI-2023-25675 WordPress Elementor plugin <= 3.16.4 - Auth. Arbitrary Attachment Read vulnerability CVSS 3.1CRITICAL 9.8
- TI-2023-26607 WordPress Elementor plugin 3.3.0-3.18.1 - Arbitrary File Upload vulnerability CVSS 3.1CRITICAL 9.9
- TI-2023-25676 WordPress Elementor Website Builder Plugin <= 3.16.4 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5
- TI-2021-07171 Elementor < 3.4.8 - DOM Cross-Site-Scripting CVSS 3.1MEDIUM 6.1
- TI-2022-11925 WordPress Elementor plugin <= 3.5.5 - Unauthenticated DOM-based Reflected Cross-Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.1
Sources
- CVE-2023-0329 · CVE Program
- CVE-2023-0329 · NVD
- FIRST EPSS
- GHSA-vfrh-jg7v-x9p3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences