Remote Code Execution via eval() Injection in amazon-redshift-python-driver
Priority MEDIUM 50CWE-94Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-94.
Summary
Unsafe use of Python's eval() on server-received data in the vector_in() function in amazon-redshift-python-driver before 2.1.14 allows a rogue server or man-in-the-middle actor to execute arbitrary code on the client. To remediate this issue, users should upgrade to version 2.1.14.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00808 57th percentileScored 2026-11-07
Fix Fixed redshift-connector (PyPI): 2.1.14
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| AWS | Amazon Redshift connector for Python | up to 2.1.13 | — | No fix listed | CNA |
| — | redshift-connector (PyPI) | before 2.1.14 | 2.1.14 | Patch available | GHSA-29h4-r29x-hchv |
- Amazon Redshift connector for Python VendorAWS Affected up to 2.1.13 Fixed in — No fix listed CNA
- redshift-connector (PyPI) Vendor— Affected before 2.1.14 Fixed in 2.1.14 Patch available GHSA-29h4-r29x-hchv
Remediation
- Fix · GHSA-29h4-r29x-hchv redshift-connector (PyPI) Fixed in 2.1.14 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-8838
- 2026-10-03 Alias added: GHSA-29h4-r29x-hchv
References
Advisory 3
More AWS vulnerabilities
- TI-2026-23989 crypto: algif_aead - Revert to operating out-of-place KEVCVSS 3.1HIGH 7.8
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2024-18648 Amazon AWS Amplify CLI before 12.10.1 incorrectly configures the role trust policy of IAM… CVSS 3.1CRITICAL 9.8
- TI-2024-05929 Openssh: regresshion - race condition in ssh allows rce/dos CVSS 3.1HIGH 8.1
- TI-2025-03847 Input validation issue in AWS Amplify Studio UI component properties CVSS 4.0CRITICAL 9.0
- TI-2026-11603 HTTP/2 Stream Parser Confusion Body-Inspection Bypass in Amazon CloudFront with AWS WAF CVSS 4.0HIGH 7.9
Sources
- CVE-2026-8838 · CVE Program
- CVE-2026-8838 · NVD
- FIRST EPSS
- GHSA-29h4-r29x-hchv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences