UI misrepresentation vulnerability in GitHub Enterprise Server allowed unauthorized…
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Active
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Spoofing
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- No fix listed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-451.
Summary
A UI misrepresentation vulnerability was identified in GitHub Enterprise Server that allowed an OAuth application to gain unintended access to an organization's runner management. An attacker could exploit this by creating an OAuth application requesting the manage_runners:org scope and directing a victim user to authorize it, as the scope was not displayed on the authorization consent screen. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.22 and was fixed in versions 3.21.2, 3.20.4, 3.19.8, 3.18.11, 3.17.17, 3.16.20. This vulnerability was reported via the GitHub Bug Bounty program.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GitHub | Enterprise Server | 3.17.0 – 3.17.16; 3.18.0 – 3.18.10; 3.19.0 – 3.19.7; 3.20.0 – 3.20.3; 3.21.0 – 3.21.1; 3.16.0 – 3.16.19 | — | No fix listed | CNA |
- Enterprise Server VendorGitHub Affected 3.17.0 – 3.17.16; 3.18.0 – 3.18.10; 3.19.0 – 3.19.7; 3.20.0 – 3.20.3; 3.21.0 – 3.21.1; 3.16.0 – 3.16.19 Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:github:enterprise_server:*:*:*:*:*:*:*:* | before 3.16.20; 3.17.0 to before 3.17.17; 3.18.0 to before 3.18.11; 3.19.0 to before 3.19.8; 3.20.0 to before 3.20.4; 3.21.0 to before 3.21.2 | Vulnerable | GitHub |
- cpe:2.3:a:github:enterprise_server:*:*:*:*:*:*:*:* Versions before 3.16.20; 3.17.0 to before 3.17.17; 3.18.0 to before 3.18.11; 3.19.0 to before 3.19.8; 3.20.0 to before 3.20.4; 3.21.0 to before 3.21.2 Vulnerable ·GitHub
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2026-9106
- 2026-10-03 Alias added: GHSA-gfj9-8v3r-jh2q
References
Other 6
- https://docs.github.com/en/[email protected]/admin/release-notes#3.17.17
- https://docs.github.com/en/[email protected]/admin/release-notes#3.18.11
- https://docs.github.com/en/[email protected]/admin/release-notes#3.19.8
- https://docs.github.com/en/[email protected]/admin/release-notes#3.20.4
- https://docs.github.com/en/[email protected]/admin/release-notes#3.21.2
- https://docs.github.com/en/[email protected]/admin/release-notes#3.16.20
More GitHub Enterprise Server vulnerabilities
- TI-2024-04632 An authentication bypass vulnerability was present in the GitHub Enterprise Server (GHES)… CVSS 4.0CRITICAL 10.0
- TI-2024-00181 Unsafe Reflection in Github Enterprise Server leading to Command Injection CVSS 3.1CRITICAL 9.8
- TI-2024-00466 Privilege Escalation by Code Injection in the Management Console in GitHub Enterprise Server CVSS 3.1HIGH 8.8
- TI-2026-03340 Remote code execution via git push option injection in GitHub Enterprise Server CVSS 4.0HIGH 8.7
- TI-2024-08804 Improper signature verification in GitHub Enterprise Server CVSS 4.0CRITICAL 9.5
- TI-2026-08177 Server-side request forgery in GitHub Enterprise Server CVSS 4.0CRITICAL 9.2
Sources
- CVE-2026-9106 · CVE Program
- CVE-2026-9106 · NVD
- FIRST EPSS
- GHSA-gfj9-8v3r-jh2q · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences