WordLift <= 3.54.10 - Unauthenticated Sensitive Information Exposure in JSON-LD REST API Endpoints
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-200.
Summary
The WordLift – AI powered SEO – Schema plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 3.54.10 via the JSON-LD REST API endpoints. This is due to the plugin registering the /wordlift/v1/jsonld/ routes (jsonld/{id}, jsonld/http/{item_id}, jsonld/post-meta/{meta_key}, jsonld/meta/{meta_key}, and jsonld/{post_type}/{post_name}) with a permission_callback of '__return_true' and the downstream converter retrieving the post via get_post() without verifying the post status or the requesting user's capabilities. This makes it possible for unauthenticated attackers to read the title, content/description, author, publication and modification dates, word count, comment count, and other metadata of private, draft, and pending posts by enumerating post IDs, bypassing WordPress core access controls.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2026-9289
- 2026-10-03 Alias added: GHSA-r68q-w69r-5c82
References
Other 10
- https://www.wordfence.com/threat-intel/vulnerabilities/id/96d8da55-0706-42b6-8423-260f6138387d?source=cve
- https://plugins.trac.wordpress.org/browser/wordlift/tags/3.54.10/classes/jsonld/class-jsonld-endpoint.php#L131
- https://plugins.trac.wordpress.org/browser/wordlift/tags/3.54.10/classes/jsonld/class-jsonld-endpoint.php#L57
- https://plugins.trac.wordpress.org/browser/wordlift/tags/3.54.10/includes/class-wordlift-post-to-jsonld-converter.php#L81
- https://plugins.trac.wordpress.org/browser/wordlift/tags/3.54.10/classes/jsonld/class-jsonld-by-id-endpoint.php#L112
- https://plugins.trac.wordpress.org/browser/wordlift/tags/3.54.8/classes/jsonld/class-jsonld-endpoint.php#L131
- https://plugins.trac.wordpress.org/browser/wordlift/tags/3.54.8/classes/jsonld/class-jsonld-endpoint.php#L57
- https://plugins.trac.wordpress.org/browser/wordlift/tags/3.54.8/includes/class-wordlift-post-to-jsonld-converter.php#L81
- https://plugins.trac.wordpress.org/browser/wordlift/tags/3.54.8/classes/jsonld/class-jsonld-by-id-endpoint.php#L112
- https://plugins.trac.wordpress.org/changeset?reponame=&old=3597515%40wordlift&new=3597515%40wordlift
More WordLift vulnerabilities
- TI-2022-02831 Wordlift < 3.37.2 - Admin+ Stored Cross-Site Scripting CVSS 3.1MEDIUM 4.8
- TI-2024-11291 WordLift – AI powered SEO – Schema <= 3.54.2 - Missing Authorization to Authenticated (Subscriber+) Settings Update CVSS 3.1MEDIUM 5.3
- TI-2025-33519 WordPress WordLift Plugin <= 3.54.5 - Cross Site Scripting (XSS) Vulnerability CVSS 3.1MEDIUM 6.5
- TI-2026-74863 WordPress WordLift plugin - Broken Access Control vulnerability CVSS 3.1MEDIUM 5.4
- TI-2025-21899 WordPress WordLift plugin <= 3.54.4 - Broken Access Control Vulnerability CVSS 3.1MEDIUM 4.3
Sources
- CVE-2026-9289 · CVE Program
- CVE-2026-9289 · NVD
- FIRST EPSS
- GHSA-r68q-w69r-5c82 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences