Insecure Deserialization in Amazon Braket SDK Job Results Processing
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Passive
- Attack complexity
- High
- Attack requirements
- Present
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-502.
Summary
Insecure deserialization in the job results processing component in Amazon Braket SDK before 1.117.0 might allow a remote authenticated user with S3 write access to the job output bucket to achieve arbitrary code execution on any machine that processes job results. We recommend you upgrade to amazon-braket-sdk version 1.117.0 or later.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| AWS | Amazon Braket Python SDK | 1.10.0 to before 1.117.0 | 1.117.0 | Patch available | CNA |
| — | amazon-braket-sdk (PyPI) | 1.10.0 to before 1.117.0 | 1.117.0 | Patch available | GHSA-g697-2xrc-gc46 |
- Amazon Braket Python SDK VendorAWS Affected 1.10.0 to before 1.117.0 Fixed in 1.117.0 Patch available CNA
- amazon-braket-sdk (PyPI) Vendor— Affected 1.10.0 to before 1.117.0 Fixed in 1.117.0 Patch available GHSA-g697-2xrc-gc46
Remediation
- Fix · CNA Amazon Braket Python SDK (AWS) Fixed in 1.117.0
- Fix · GHSA-g697-2xrc-gc46 amazon-braket-sdk (PyPI) Fixed in 1.117.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-9291
- 2026-10-03 Alias added: GHSA-g697-2xrc-gc46
- 2026-10-16 EPSS moved to the 50th–90th percentile
- 2026-10-25 EPSS moved to the below the 50th percentile
References
Advisory 3
More AWS vulnerabilities
- TI-2026-23989 crypto: algif_aead - Revert to operating out-of-place KEVCVSS 3.1HIGH 7.8
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2024-18648 Amazon AWS Amplify CLI before 12.10.1 incorrectly configures the role trust policy of IAM… CVSS 3.1CRITICAL 9.8
- TI-2024-05929 Openssh: regresshion - race condition in ssh allows rce/dos CVSS 3.1HIGH 8.1
- TI-2025-03847 Input validation issue in AWS Amplify Studio UI component properties CVSS 4.0CRITICAL 9.0
- TI-2026-11603 HTTP/2 Stream Parser Confusion Body-Inspection Bypass in Amazon CloudFront with AWS WAF CVSS 4.0HIGH 7.9
Sources
- CVE-2026-9291 · CVE Program
- CVE-2026-9291 · NVD
- FIRST EPSS
- GHSA-g697-2xrc-gc46 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences