Code injection via improper triple-quote escaping in AgentCore CLI Bedrock Agent import
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Active
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-94.
Summary
Improper neutralization of triple-quote characters during Python code generation in AgentCore CLI before v0.14.2 might allow an authenticated remote threat actor to execute arbitrary code on AWS AgentCore Runtime under the imported agent's IAM execution role and on the local environment of another user in the same AWS account, via a crafted collaborationInstruction stored on a Bedrock Agent collaborator and later processed by that other user during agent import. To remediate this issue, users should upgrade to version 0.14.2.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| AWS | AgentCore CLI | 0.4.0 – 0.14.1; 0.3.0-preview.7.0 – 1.0.0-preview.8 | — | No fix listed | CNA |
| — | @aws/agentcore (npm) | 0.4.0 to before 0.14.2 | 0.14.2 | Patch available | GHSA-m4x6-gwgp-4pm7 |
| — | @aws/agentcore (npm) | 0.3.0-preview.7.0 – 0.3.0-preview.9.0 | — | No fix listed | GHSA-m4x6-gwgp-4pm7 |
| — | @aws/agentcore (npm) | 1.0.0-preview.1 to before 1.0.0-preview.9 | 1.0.0-preview.9 | Patch available | GHSA-m4x6-gwgp-4pm7 |
- AgentCore CLI VendorAWS Affected 0.4.0 – 0.14.1; 0.3.0-preview.7.0 – 1.0.0-preview.8 Fixed in — No fix listed CNA
- @aws/agentcore (npm) Vendor— Affected 0.4.0 to before 0.14.2 Fixed in 0.14.2 Patch available GHSA-m4x6-gwgp-4pm7
- @aws/agentcore (npm) Vendor— Affected 0.3.0-preview.7.0 – 0.3.0-preview.9.0 Fixed in — No fix listed GHSA-m4x6-gwgp-4pm7
- @aws/agentcore (npm) Vendor— Affected 1.0.0-preview.1 to before 1.0.0-preview.9 Fixed in 1.0.0-preview.9 Patch available GHSA-m4x6-gwgp-4pm7
Remediation
- Fix · GHSA-m4x6-gwgp-4pm7 @aws/agentcore (npm) Fixed in 0.14.2 Advisory →
- Fix · GHSA-m4x6-gwgp-4pm7 @aws/agentcore (npm) Fixed in 1.0.0-preview.9 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-11393
- 2026-10-03 Alias added: GHSA-m4x6-gwgp-4pm7
References
Patch 3
Advisory 3
More AWS vulnerabilities
- TI-2026-23989 crypto: algif_aead - Revert to operating out-of-place KEVCVSS 3.1HIGH 7.8
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2024-18648 Amazon AWS Amplify CLI before 12.10.1 incorrectly configures the role trust policy of IAM… CVSS 3.1CRITICAL 9.8
- TI-2024-05929 Openssh: regresshion - race condition in ssh allows rce/dos CVSS 3.1HIGH 8.1
- TI-2025-03847 Input validation issue in AWS Amplify Studio UI component properties CVSS 4.0CRITICAL 9.0
- TI-2026-11603 HTTP/2 Stream Parser Confusion Body-Inspection Bypass in Amazon CloudFront with AWS WAF CVSS 4.0HIGH 7.9
Sources
- CVE-2026-11393 · CVE Program
- CVE-2026-11393 · NVD
- FIRST EPSS
- GHSA-m4x6-gwgp-4pm7 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences