Privilege Escalation in AWS Advanced JDBC Wrapper for Amazon Aurora PostgreSQL
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-426.
Summary
An untrusted search path issue in the GlobalDatabasePlugin in the AWS Advanced JDBC Wrapper for Amazon Aurora PostgreSQL will allow a remote authenticated low-privilege actor to escalate privileges to those of another Amazon RDS user, including rds_superuser, via a crafted function created by the actor that runs when that user connects to the cluster through an affected wrapper. To remediate this issue, users should upgrade to AWS Advanced JDBC Wrapper version 4.0.1.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| AWS | AWS Advanced JDBC Wrapper | 3.0.0 to before 4.0.1 | 4.0.1 | Patch available | CNA |
| — | software.amazon.jdbc:aws-advanced-jdbc-wrapper (Maven) | 3.0.0 to before 4.0.1 | 4.0.1 | Patch available | GHSA-mhww-p97m-3368 |
- AWS Advanced JDBC Wrapper VendorAWS Affected 3.0.0 to before 4.0.1 Fixed in 4.0.1 Patch available CNA
- software.amazon.jdbc:aws-advanced-jdbc-wrapper (Maven) Vendor— Affected 3.0.0 to before 4.0.1 Fixed in 4.0.1 Patch available GHSA-mhww-p97m-3368
Remediation
- Fix · CNA AWS Advanced JDBC Wrapper (AWS) Fixed in 4.0.1
- Fix · GHSA-mhww-p97m-3368 software.amazon.jdbc:aws-advanced-jdbc-wrapper (Maven) Fixed in 4.0.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-11400
- 2026-10-03 Alias added: GHSA-mhww-p97m-3368
- 2026-10-20 1 new reference · CNA
- 2026-10-25 Priority changed: LOW → MEDIUM
References
Advisory 3
More AWS vulnerabilities
- TI-2026-23989 crypto: algif_aead - Revert to operating out-of-place KEVCVSS 3.1HIGH 7.8
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2024-18648 Amazon AWS Amplify CLI before 12.10.1 incorrectly configures the role trust policy of IAM… CVSS 3.1CRITICAL 9.8
- TI-2024-05929 Openssh: regresshion - race condition in ssh allows rce/dos CVSS 3.1HIGH 8.1
- TI-2025-03847 Input validation issue in AWS Amplify Studio UI component properties CVSS 4.0CRITICAL 9.0
- TI-2026-11603 HTTP/2 Stream Parser Confusion Body-Inspection Bypass in Amazon CloudFront with AWS WAF CVSS 4.0HIGH 7.9
Sources
- CVE-2026-11400 · CVE Program
- CVE-2026-11400 · NVD
- FIRST EPSS
- GHSA-mhww-p97m-3368 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences