Privilege Escalation in AWS Advanced Go Wrapper for Amazon Aurora PostgreSQL
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-426.
Summary
An untrusted search path issue in the GlobalDatabasePlugin in the AWS Advanced Go Wrapper for Amazon Aurora PostgreSQL will allow a remote authenticated low-privilege actor to escalate privileges to those of another Amazon RDS user, including rds_superuser, via a crafted function created by the actor that runs when that user connects to the cluster through the affected wrapper. To remediate this issue, users should upgrade to the AWS Advanced Go Wrapper release 2026-05-26
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| AWS | AWS Advanced Go Wrapper | 2026-04-06 to before 2026-05-26 | 2026-05-26 | Patch available | CNA |
| — | github.com/aws/aws-advanced-go-wrapper/awssql/v2 (Go) | before 2.0.1 | 2.0.1 | Patch available | GHSA-r236-5pc3-3qcp |
| — | github.com/aws/aws-advanced-go-wrapper/xray (Go) | before 1.07 | 1.07 | Patch available | GHSA-r236-5pc3-3qcp |
| — | github.com/aws/aws-advanced-go-wrapper/aws-secrets-manager (Go) | before 1.1.2 | 1.1.2 | Patch available | GHSA-r236-5pc3-3qcp |
| — | github.com/aws/aws-advanced-go-wrapper/custom-endpoint (Go) | before 1.0.4 | 1.0.4 | Patch available | GHSA-r236-5pc3-3qcp |
| — | github.com/aws/aws-advanced-go-wrapper/federated-auth (Go) | before 1.1.1 | 1.1.1 | Patch available | GHSA-r236-5pc3-3qcp |
| — | github.com/aws/aws-advanced-go-wrapper/iam (Go) | before 1.1.1 | 1.1.1 | Patch available | GHSA-r236-5pc3-3qcp |
| — | github.com/aws/aws-advanced-go-wrapper/mysql-driver (Go) | before 1.1.1 | 1.1.1 | Patch available | GHSA-r236-5pc3-3qcp |
| — | github.com/aws/aws-advanced-go-wrapper/okta (Go) | before 1.1.1 | 1.1.1 | Patch available | GHSA-r236-5pc3-3qcp |
| — | github.com/aws/aws-advanced-go-wrapper/pgx-driver (Go) | before 1.1.1 | 1.1.1 | Patch available | GHSA-r236-5pc3-3qcp |
| — | github.com/aws/aws-advanced-go-wrapper/otlp (Go) | before 1.0.7 | 1.0.7 | Patch available | GHSA-r236-5pc3-3qcp |
| — | github.com/aws/aws-advanced-go-wrapper/auth-helpers (Go) | before 1.1.1 | 1.1.1 | Patch available | GHSA-r236-5pc3-3qcp |
- AWS Advanced Go Wrapper VendorAWS Affected 2026-04-06 to before 2026-05-26 Fixed in 2026-05-26 Patch available CNA
- github.com/aws/aws-advanced-go-wrapper/awssql/v2 (Go) Vendor— Affected before 2.0.1 Fixed in 2.0.1 Patch available GHSA-r236-5pc3-3qcp
- github.com/aws/aws-advanced-go-wrapper/xray (Go) Vendor— Affected before 1.07 Fixed in 1.07 Patch available GHSA-r236-5pc3-3qcp
- github.com/aws/aws-advanced-go-wrapper/aws-secrets-manager (Go) Vendor— Affected before 1.1.2 Fixed in 1.1.2 Patch available GHSA-r236-5pc3-3qcp
- github.com/aws/aws-advanced-go-wrapper/custom-endpoint (Go) Vendor— Affected before 1.0.4 Fixed in 1.0.4 Patch available GHSA-r236-5pc3-3qcp
- github.com/aws/aws-advanced-go-wrapper/federated-auth (Go) Vendor— Affected before 1.1.1 Fixed in 1.1.1 Patch available GHSA-r236-5pc3-3qcp
- github.com/aws/aws-advanced-go-wrapper/iam (Go) Vendor— Affected before 1.1.1 Fixed in 1.1.1 Patch available GHSA-r236-5pc3-3qcp
- github.com/aws/aws-advanced-go-wrapper/mysql-driver (Go) Vendor— Affected before 1.1.1 Fixed in 1.1.1 Patch available GHSA-r236-5pc3-3qcp
- github.com/aws/aws-advanced-go-wrapper/okta (Go) Vendor— Affected before 1.1.1 Fixed in 1.1.1 Patch available GHSA-r236-5pc3-3qcp
- github.com/aws/aws-advanced-go-wrapper/pgx-driver (Go) Vendor— Affected before 1.1.1 Fixed in 1.1.1 Patch available GHSA-r236-5pc3-3qcp
- github.com/aws/aws-advanced-go-wrapper/otlp (Go) Vendor— Affected before 1.0.7 Fixed in 1.0.7 Patch available GHSA-r236-5pc3-3qcp
- github.com/aws/aws-advanced-go-wrapper/auth-helpers (Go) Vendor— Affected before 1.1.1 Fixed in 1.1.1 Patch available GHSA-r236-5pc3-3qcp
Remediation
- Fix · CNA AWS Advanced Go Wrapper (AWS) Fixed in 2026-05-26
- Fix · GHSA-r236-5pc3-3qcp github.com/aws/aws-advanced-go-wrapper/awssql/v2 (Go) Fixed in 2.0.1 Advisory →
- Fix · GHSA-r236-5pc3-3qcp github.com/aws/aws-advanced-go-wrapper/xray (Go) Fixed in 1.07 Advisory →
- Fix · GHSA-r236-5pc3-3qcp github.com/aws/aws-advanced-go-wrapper/aws-secrets-manager (Go) Fixed in 1.1.2 Advisory →
- Fix · GHSA-r236-5pc3-3qcp github.com/aws/aws-advanced-go-wrapper/custom-endpoint (Go) Fixed in 1.0.4 Advisory →
- Fix · GHSA-r236-5pc3-3qcp github.com/aws/aws-advanced-go-wrapper/federated-auth (Go) Fixed in 1.1.1 Advisory →
- Fix · GHSA-r236-5pc3-3qcp github.com/aws/aws-advanced-go-wrapper/iam (Go) Fixed in 1.1.1 Advisory →
- Fix · GHSA-r236-5pc3-3qcp github.com/aws/aws-advanced-go-wrapper/mysql-driver (Go) Fixed in 1.1.1 Advisory →
- Fix · GHSA-r236-5pc3-3qcp github.com/aws/aws-advanced-go-wrapper/okta (Go) Fixed in 1.1.1 Advisory →
- Fix · GHSA-r236-5pc3-3qcp github.com/aws/aws-advanced-go-wrapper/pgx-driver (Go) Fixed in 1.1.1 Advisory →
- Fix · GHSA-r236-5pc3-3qcp github.com/aws/aws-advanced-go-wrapper/otlp (Go) Fixed in 1.0.7 Advisory →
- Fix · GHSA-r236-5pc3-3qcp github.com/aws/aws-advanced-go-wrapper/auth-helpers (Go) Fixed in 1.1.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-11401
- 2026-10-03 Alias added: GHSA-r236-5pc3-3qcp
References
Advisory 3
More AWS vulnerabilities
- TI-2026-23989 crypto: algif_aead - Revert to operating out-of-place KEVCVSS 3.1HIGH 7.8
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2024-18648 Amazon AWS Amplify CLI before 12.10.1 incorrectly configures the role trust policy of IAM… CVSS 3.1CRITICAL 9.8
- TI-2024-05929 Openssh: regresshion - race condition in ssh allows rce/dos CVSS 3.1HIGH 8.1
- TI-2025-03847 Input validation issue in AWS Amplify Studio UI component properties CVSS 4.0CRITICAL 9.0
- TI-2026-11603 HTTP/2 Stream Parser Confusion Body-Inspection Bypass in Amazon CloudFront with AWS WAF CVSS 4.0HIGH 7.9
Sources
- CVE-2026-11401 · CVE Program
- CVE-2026-11401 · NVD
- FIRST EPSS
- GHSA-r236-5pc3-3qcp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences