OS Command Injection in NodejsFunction Bundling in aws-cdk-lib
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- Active
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-78.
Summary
OS command injection in the NodejsFunction local bundling pipeline in aws-cdk-lib before 2.245.0 (2.246.0 on Windows) might allow an actor who controls the value of one or more bundling properties (externalModules, define, loader, inject, or esbuildArgs) to execute arbitrary commands on the host running the CDK toolchain via injected shell metacharacters. This issue requires the threat actor to control the value of one or more of the affected bundling properties in the CDK application. To remediate this issue, users should upgrade to aws-cdk-lib 2.245.0 (2.246.0 on Windows) or later.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| AWS | AWS Cloud Development Kit library | before 2.245.0 | 2.245.0 | Patch available | CNA |
| — | aws-cdk-lib (npm) | before 2.246.0 | 2.246.0 | Patch available | GHSA-999r-qq7v-r334 |
- AWS Cloud Development Kit library VendorAWS Affected before 2.245.0 Fixed in 2.245.0 Patch available CNA
- aws-cdk-lib (npm) Vendor— Affected before 2.246.0 Fixed in 2.246.0 Patch available GHSA-999r-qq7v-r334
Remediation
- Fix · CNA AWS Cloud Development Kit library (AWS) Fixed in 2.245.0
- Fix · GHSA-999r-qq7v-r334 aws-cdk-lib (npm) Fixed in 2.246.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-11417
- 2026-10-03 Alias added: GHSA-999r-qq7v-r334
References
Advisory 3
More AWS vulnerabilities
- TI-2026-23989 crypto: algif_aead - Revert to operating out-of-place KEVCVSS 3.1HIGH 7.8
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2024-18648 Amazon AWS Amplify CLI before 12.10.1 incorrectly configures the role trust policy of IAM… CVSS 3.1CRITICAL 9.8
- TI-2024-05929 Openssh: regresshion - race condition in ssh allows rce/dos CVSS 3.1HIGH 8.1
- TI-2025-03847 Input validation issue in AWS Amplify Studio UI component properties CVSS 4.0CRITICAL 9.0
- TI-2026-11603 HTTP/2 Stream Parser Confusion Body-Inspection Bypass in Amazon CloudFront with AWS WAF CVSS 4.0HIGH 7.9
Sources
- CVE-2026-11417 · CVE Program
- CVE-2026-11417 · NVD
- FIRST EPSS
- GHSA-999r-qq7v-r334 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences