Read the docs
TI-2026-10648 Aliases CVE-2026-12402GHSA-wm5w-wf8v-v7qm

Cross-site scripting in xootix OTP Login & Register Woocommerce

Priority LOW 20CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
None
Attack complexity
High
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
No fix listed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.

Summary

The OTP Login & Register Woocommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via 'fb-config' Setting in all versions up to, and including, 2.7.3 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. On multisite installations where administrators do not hold the unfiltered_html capability, this vulnerability can be leveraged to target the network super administrator.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00311 24th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
xootixOTP Login & Register Woocommerceup to 2.7.3—No fix listedCNA
  • OTP Login & Register Woocommerce Vendorxootix Affected up to 2.7.3 Fixed in — No fix listed CNA

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-12402
  2. 2026-10-03 Alias added: GHSA-wm5w-wf8v-v7qm

References

  • TI-2024-04943 XootiX Framework <= Various Plugin Versions - Missing Authorization to Arbitrary Options Update CVSS 3.1HIGH 8.8
  • TI-2022-00152 XootiX Plugins <= Various Versions Cross-Site Request Forgery to Arbitrary Options Update CVSS 3.1HIGH 8.8
  • TI-2023-02534 OTP Login Woocommerce & Gravity Forms <= 2.2 - Authentication Bypass to Privilege Escalation CVSS 3.1HIGH 8.1
  • TI-2022-22342 WordPress Side Cart Woocommerce (Ajax) Plugin < 2.1 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
  • TI-2020-18886 Login/Signup Popup < 1.5 - Missing Authorization CVSS 3.1HIGH 7.4
  • TI-2026-10507 OTP Login & Register Woocommerce <= 2.7.2 - Unauthenticated Authentication Bypass via Brute Force CVSS 3.1MEDIUM 5.3
See all 14 →

Sources