OS command injection in jsii-diff in AWS jsii
Priority MEDIUM 41CWE-78Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Active
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-78.
Summary
OS command injection in the npm package loading component in AWS jsii-diff before 1.131.0 might allow context-dependent attackers to execute arbitrary commands via crafted package specifiers passed to the npm: source argument. To mitigate this issue, users should upgrade to jsii-diff v1.131.0 or later.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01081 65th percentileScored 2026-11-07
Fix Fixed jsii (AWS): 1.131.0jsii-diff (npm): 1.131.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| AWS | jsii | before 1.131.0 | 1.131.0 | Patch available | CNA |
| — | jsii-diff (npm) | before 1.131.0 | 1.131.0 | Patch available | GHSA-wcx4-wpfv-mc5c |
- jsii VendorAWS Affected before 1.131.0 Fixed in 1.131.0 Patch available CNA
- jsii-diff (npm) Vendor— Affected before 1.131.0 Fixed in 1.131.0 Patch available GHSA-wcx4-wpfv-mc5c
Remediation
- Fix · CNA jsii (AWS) Fixed in 1.131.0
- Fix · GHSA-wcx4-wpfv-mc5c jsii-diff (npm) Fixed in 1.131.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-15895
- 2026-10-03 Alias added: GHSA-wcx4-wpfv-mc5c
References
Advisory 2
More AWS vulnerabilities
- TI-2026-23989 crypto: algif_aead - Revert to operating out-of-place KEVCVSS 3.1HIGH 7.8
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2024-18648 Amazon AWS Amplify CLI before 12.10.1 incorrectly configures the role trust policy of IAM… CVSS 3.1CRITICAL 9.8
- TI-2024-05929 Openssh: regresshion - race condition in ssh allows rce/dos CVSS 3.1HIGH 8.1
- TI-2025-03847 Input validation issue in AWS Amplify Studio UI component properties CVSS 4.0CRITICAL 9.0
- TI-2026-11603 HTTP/2 Stream Parser Confusion Body-Inspection Bypass in Amazon CloudFront with AWS WAF CVSS 4.0HIGH 7.9
Sources
- CVE-2026-15895 · CVE Program
- CVE-2026-15895 · NVD
- FIRST EPSS
- GHSA-wcx4-wpfv-mc5c · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences