AWS API MCP Server Security Policy Bypass via Startup Failure
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub.
Summary
Improper handling of an initialization failure in AWS API MCP Server from 0.2.13 through 1.3.46 might allow an actor to bypass the user-configured security policy and execute AWS API operations that the policy was set to deny or gate. When initialization of the security policy enforcement data fails at server startup, the policy check is skipped for the lifetime of the process. IAM permissions on the configured credentials remain in effect and are unaffected. To remediate this issue, users should upgrade to version 1.3.47.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| AWS | aws-api-mcp-server | 0.2.13 to before 1.3.47 | 1.3.47 | Patch available | CNA |
| — | awslabs.aws-api-mcp-server (PyPI) | 0.2.13 to before 1.3.47 | 1.3.47 | Patch available | GHSA-29w2-fq35-v728 |
- aws-api-mcp-server VendorAWS Affected 0.2.13 to before 1.3.47 Fixed in 1.3.47 Patch available CNA
- awslabs.aws-api-mcp-server (PyPI) Vendor— Affected 0.2.13 to before 1.3.47 Fixed in 1.3.47 Patch available GHSA-29w2-fq35-v728
Remediation
- Fix · CNA aws-api-mcp-server (AWS) Fixed in 1.3.47
- Fix · GHSA-29w2-fq35-v728 awslabs.aws-api-mcp-server (PyPI) Fixed in 1.3.47 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-16584
- 2026-10-03 Alias added: GHSA-29w2-fq35-v728
References
Advisory 2
Other 6
- https://github.com/awslabs/mcp/security/advisories/GHSA-29w2-fq35-v728
- https://github.com/awslabs/mcp/pull/4315
- https://github.com/awslabs/mcp/commit/ab1bbebc097d674c1cdd4bd75a8f313be18473bf
- https://aws.amazon.com/security/security-bulletins/2026-063-aws
- https://github.com/awslabs/mcp
- https://pypi.org/project/awslabs.aws-api-mcp-server/1.3.47
More AWS vulnerabilities
- TI-2026-23989 crypto: algif_aead - Revert to operating out-of-place KEVCVSS 3.1HIGH 7.8
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2024-18648 Amazon AWS Amplify CLI before 12.10.1 incorrectly configures the role trust policy of IAM… CVSS 3.1CRITICAL 9.8
- TI-2024-05929 Openssh: regresshion - race condition in ssh allows rce/dos CVSS 3.1HIGH 8.1
- TI-2025-03847 Input validation issue in AWS Amplify Studio UI component properties CVSS 4.0CRITICAL 9.0
- TI-2026-11603 HTTP/2 Stream Parser Confusion Body-Inspection Bypass in Amazon CloudFront with AWS WAF CVSS 4.0HIGH 7.9
Sources
- CVE-2026-16584 · CVE Program
- CVE-2026-16584 · NVD
- FIRST EPSS
- GHSA-29w2-fq35-v728 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences