Code injection in Atlassian Bamboo Data Center
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-94.
Summary
This High severity RCE (Remote Code Execution) vulnerability was introduced in versions 9.6.0, 10.0.0, 10.1.0, 10.2.0, 11.0.0, 11.1.0, 12.0.0, and 12.1.0 of Bamboo Data Center. This RCE (Remote Code Execution) vulnerability, with a CVSS Score of 8.6, allows an authenticated attacker to execute malicious code on the remote system. Atlassian recommends that Bamboo Data Center customers upgrade to latest version, if you are unable to do so, upgrade your instance to one of the specified supported fixed versions: Bamboo Data Center 9.6: Upgrade to a release greater than or equal to 9.6.24 Bamboo Data Center 10.2: Upgrade to a release greater than or equal to 10.2.16 Bamboo Data Center 12.1: Upgrade to a release greater than or equal to 12.1.3 See the release notes ([https://confluence.atlassian.com/bambooreleases/bamboo-release-notes-1189793869.html]). You can download the latest version of Bamboo Data Center from the download center ([https://www.atlassian.com/software/bamboo/download-archives]). This vulnerability was reported via our Atlassian (Internal) program.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Atlassian | Bamboo Data Center | 12.1.0 to 12.1.2; 12.0.0 to 12.0.2; 11.0.0 to 11.0.8; 10.2.0 to 10.2.15; 10.1.0 to 10.1.1; 10.0.0 to 10.0.3; 9.6.1 to 9.6.23 | 12.1.3, 10.2.16, 9.6.24 | Patch available | CNA |
- Bamboo Data Center VendorAtlassian Affected 12.1.0 to 12.1.2; 12.0.0 to 12.0.2; 11.0.0 to 11.0.8; 10.2.0 to 10.2.15; 10.1.0 to 10.1.1; 10.0.0 to 10.0.3; 9.6.1 to 9.6.23 Fixed in 12.1.3, 10.2.16, 9.6.24 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:atlassian:bamboo:*:*:*:*:*:*:*:* | 9.6.1 to before 9.6.24; 10.0.0 to before 10.2.16; 11.0.0 to before 12.1.3 | Vulnerable | Atlassian |
- cpe:2.3:a:atlassian:bamboo:*:*:*:*:*:*:*:* Versions 9.6.1 to before 9.6.24; 10.0.0 to before 10.2.16; 11.0.0 to before 12.1.3 Vulnerable ·Atlassian
Remediation
- Fix · CNA Bamboo Data Center (Atlassian) Fixed in 12.1.3, 10.2.16, 9.6.24
Timeline
- 2026-10-02 Threatist record created from CVE-2026-21570
- 2026-10-03 Alias added: GHSA-c7mx-5c2c-78hh
References
More Atlassian Bamboo vulnerabilities
- TI-2026-67904 Arbitrary file access in Atlassian Data Center products KEVCVSS 4.0CRITICAL 9.3
- TI-2012-02540 Atlassian JIRA before 5.0.1; Confluence before 3.5.16, 4.0 before 4.0.7, and 4.1 before… CVSS 3.1CRITICAL 9.1
- TI-2022-09598 Improper authentication in Atlassian Bamboo Server CVSS 3.1CRITICAL 9.8
- TI-2016-04529 Atlassian Bamboo before 5.11.4.1 and 5.12.x before 5.12.3.1 does not properly restrict… CVSS 3.0CRITICAL 9.8
- TI-2015-06881 An unspecified resource in Atlassian Bamboo before 5.9.9 and 5.10.x before 5.10.0 allows… CVSS 3.0CRITICAL 9.8
- TI-2014-07936 The Ignite Realtime Smack XMPP API, as used in Atlassian Bamboo before 5.9.9 and 5.10.x… CVSS 3.0CRITICAL 9.8
Sources
- CVE-2026-21570 · CVE Program
- CVE-2026-21570 · NVD
- FIRST EPSS
- GHSA-c7mx-5c2c-78hh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences