Read the docs
TI-2026-17406 Aliases CVE-2026-21584GHSA-6ghh-4pm9-h5h5

Improper authorization in Atlassian Bamboo Data Center

Priority LOW 36CWE-285Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Attack requirements
Present
Impact type
Security bypass
Confidentiality · integrity · availability
High · High · None
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-285.

Summary

This High severity Improper Authorization vulnerability was introduced in versions 10.0.0, 10.1.0, 10.2.0, 11.0.0, 12.0.0, and 12.1.0 of Bamboo Data Center. This Improper Authorization vulnerability, with a CVSS Score of 7.6, allows an authenticated attacker to gain unintended access and can lead to the exposure of resources or functionality, possibly providing attackers with sensitive information or even execute arbitrary code. Atlassian recommends that Bamboo Data Center customers upgrade to latest version, if you are unable to do so, upgrade your instance to one of the specified supported fixed versions: * Bamboo Data Center 10.2: Upgrade to a release greater than or equal to 10.2.22 * Bamboo Data Center 12.1: Upgrade to a release greater than or equal to 12.1.10 See the release notes (https://confluence.atlassian.com/bambooreleases/bamboo-release-notes-1189793869.html). You can download the latest version of Bamboo Data Center from the download center (https://www.atlassian.com/software/bamboo/download-archives). This vulnerability was reported via our Penetration Testing program.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0046 40th percentileScored 2026-11-07
Fix Fixed Bamboo Data Center (Atlassian): 12.1.10, 10.2.22

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
AtlassianBamboo Data Center12.1.0 to 12.1.9; 12.0.0 to 12.0.2; 11.0.0 to 11.0.8; 10.2.0 to 10.2.21; 10.1.0 to 10.1.1; 10.0.0 to 10.0.312.1.10, 10.2.22Patch availableCNA
  • Bamboo Data Center VendorAtlassian Affected 12.1.0 to 12.1.9; 12.0.0 to 12.0.2; 11.0.0 to 11.0.8; 10.2.0 to 10.2.21; 10.1.0 to 10.1.1; 10.0.0 to 10.0.3 Fixed in 12.1.10, 10.2.22 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:atlassian:bamboo:*:*:*:*:*:*:*:*10.0.0 to before 10.2.22; 11.0.0 to before 12.1.10VulnerableAtlassian
  • cpe:2.3:a:atlassian:bamboo:*:*:*:*:*:*:*:* Versions 10.0.0 to before 10.2.22; 11.0.0 to before 12.1.10 Vulnerable ·Atlassian

Remediation

  • Fix · CNA Bamboo Data Center (Atlassian) Fixed in 12.1.10, 10.2.22

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-21584
  2. 2026-10-03 Alias added: GHSA-6ghh-4pm9-h5h5

References

  • TI-2026-67904 Arbitrary file access in Atlassian Data Center products KEVCVSS 4.0CRITICAL 9.3
  • TI-2012-02540 Atlassian JIRA before 5.0.1; Confluence before 3.5.16, 4.0 before 4.0.7, and 4.1 before… CVSS 3.1CRITICAL 9.1
  • TI-2022-09598 Improper authentication in Atlassian Bamboo Server CVSS 3.1CRITICAL 9.8
  • TI-2016-04529 Atlassian Bamboo before 5.11.4.1 and 5.12.x before 5.12.3.1 does not properly restrict… CVSS 3.0CRITICAL 9.8
  • TI-2015-06881 An unspecified resource in Atlassian Bamboo before 5.9.9 and 5.10.x before 5.10.0 allows… CVSS 3.0CRITICAL 9.8
  • TI-2014-07936 The Ignite Realtime Smack XMPP API, as used in Atlassian Bamboo before 5.9.9 and 5.10.x… CVSS 3.0CRITICAL 9.8
See all 27 →

Sources