CryptoLib Memory Leak in KMC Encrypt Function Leads to Resource Exhaustion
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · Low
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-401.
Summary
CryptoLib provides a software-only solution using the CCSDS Space Data Link Security Protocol - Extended Procedures (SDLS-EP) to secure communications between a spacecraft running the core Flight System (cFS) and a ground station. Prior to version 1.4.3, the cryptography_encrypt() function allocates multiple buffers for HTTP requests and JSON parsing that are never freed on any code path. Each call leaks approximately 400 bytes of memory. Sustained traffic can gradually exhaust available memory. This issue has been patched in version 1.4.3.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA CryptoLib (nasa) Fixed in 1.4.3
Timeline
- 2026-10-02 Threatist record created from CVE-2026-22024
References
More nasa Cryptolib vulnerabilities
- TI-2025-21552 CryptoLib Has Heap Overflow in Crypto_TM_ProcessSecurity due to Unchecked Secondary Header Length CVSS 3.1CRITICAL 9.4
- TI-2025-21662 Heap Buffer Overflow via Incomplete Length Check in `Crypto_TC_ApplySecurity` CVSS 4.0CRITICAL 9.3
- TI-2025-21298 CryptoLib's Crypto_TC_Prep_AAD Has Buffer Overflow Due to Integer Underflow CVSS 4.0HIGH 8.9
- TI-2025-21297 CryptoLib Has Heap Buffer Overflow Due to Unsigned Integer Underflow in Crypto_TC_ProcessSecurity CVSS 4.0HIGH 8.9
- TI-2025-21296 CryptoLib Has Heap Buffer Overflow in Crypto_AOS_ProcessSecurity Function CVSS 4.0HIGH 8.9
- TI-2025-21294 CryptoLib's Crypto_TC_ApplySecurity() Has a Heap Buffer Overflow Vulnerability CVSS 4.0HIGH 8.9
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences