wpDiscuz before 7.6.47 - Stored Cross-Site Scripting in Inline Comment Preview
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
wpDiscuz before 7.6.47 contains a stored cross-site scripting vulnerability in the inline comment preview functionality that allows authenticated users to inject malicious scripts by submitting comments with unescaped content. Attackers with unfiltered_html capabilities can inject JavaScript directly through comment content rendered in the AJAX response from the getLastInlineComments() function in class.WpdiscuzHelperAjax.php without proper HTML escaping.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| gVectors Team | wpDiscuz | before 7.6.47 | 7.6.47 | Patch available | CNA |
- wpDiscuz VendorgVectors Team Affected before 7.6.47 Fixed in 7.6.47 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gvectors:wpdiscuz:*:*:*:*:*:wordpress:*:* | before 7.6.47 | Vulnerable | gVectors Team |
- cpe:2.3:a:gvectors:wpdiscuz:*:*:*:*:*:wordpress:*:* Versions before 7.6.47 Vulnerable ·gVectors Team
Remediation
- Fix · CNA wpDiscuz (gVectors) Fixed in 7.6.47
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
gVectors wpDiscuz 7.6.47
11 records Highest priority Priority MEDIUM 2 MEDIUM, 9 LOW
Other records, highest priority first
- TI-2026-17792 wpDiscuz before 7.6.47 - Unauthenticated Email Notification Flood via wpdCheckNotificationTypePriority MEDIUM 44
- TI-2026-17803 wpDiscuz before 7.6.47 - SQL Injection in getAllSubscriptions()Priority MEDIUM 42
- TI-2026-17826 wpDiscuz before 7.6.47 - No Rate Limiting on Subscription Endpoints with LIKE Wildcard BypassPriority LOW 36
Timeline
- 2026-10-02 Threatist record created from CVE-2026-22183
- 2026-10-03 Alias added: GHSA-fffh-m74r-q8cx
References
Patch 1
Other 1
More gVectors Team Wpdiscuz vulnerabilities
- TI-2020-14828 A Remote Code Execution vulnerability exists in the gVectors wpDiscuz plugin 7.0 through… CVSS 3.1CRITICAL 10.0
- TI-2026-17809 Voltronic Power SNMP Web Pro 1.1 Path Traversal via upload.cgi CVSS 4.0HIGH 8.7
- TI-2020-10702 A SQL injection issue in the gVectors wpDiscuz plugin 5.3.5 and earlier for WordPress… CVSS 3.1CRITICAL 9.8
- TI-2026-17792 wpDiscuz before 7.6.47 - Unauthenticated Email Notification Flood via wpdCheckNotificationType CVSS 4.0HIGH 8.7
- TI-2024-08805 Comments – wpDiscuz <= 7.6.24 - Authentication Bypass via WordPress.com OAuth provider CVSS 3.1CRITICAL 9.8
- TI-2026-17803 wpDiscuz before 7.6.47 - SQL Injection in getAllSubscriptions() CVSS 4.0CRITICAL 9.2
Sources
- CVE-2026-22183 · CVE Program
- CVE-2026-22183 · NVD
- FIRST EPSS
- GHSA-fffh-m74r-q8cx · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences