Read the docs
TI-2026-19160 Aliases CVE-2026-23794GHSA-v84m-gfw5-hm2w

Apache Syncope: Reflected XSS on Enduser Login

Priority LOW 31CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
High · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

Reflected XSS in Apache Syncope's Enduser Login page. An attacker that tricks a legitimate user into clicking a malicious link and logging in to Syncope Enduser could steal that user's credentials. This issue affects Apache Syncope: from 3.0 through 3.0.15, from 4.0 through 4.0.3. Users are recommended to upgrade to version 3.0.16 / 4.0.4, which fix this issue.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00524 44th percentileScored 2026-11-07
Fix Fixed org.apache.syncope.client.idrepo:syncope-client-idrepo-common-ui (Maven): 3.0.16, 4.0.4

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ApacheApache Syncope3.0 – 3.0.15; 4.0 – 4.0.3—No fix listedCNA
—org.apache.syncope.client.idrepo:syncope-client-idrepo-common-ui (Maven)3.0.0 to before 3.0.163.0.16Patch availableGHSA-v84m-gfw5-hm2w
—org.apache.syncope.client.idrepo:syncope-client-idrepo-common-ui (Maven)4.0.0 to before 4.0.44.0.4Patch availableGHSA-v84m-gfw5-hm2w
  • Apache Syncope VendorApache Affected 3.0 – 3.0.15; 4.0 – 4.0.3 Fixed in — No fix listed CNA
  • org.apache.syncope.client.idrepo:syncope-client-idrepo-common-ui (Maven) Vendor— Affected 3.0.0 to before 3.0.16 Fixed in 3.0.16 Patch available GHSA-v84m-gfw5-hm2w
  • org.apache.syncope.client.idrepo:syncope-client-idrepo-common-ui (Maven) Vendor— Affected 4.0.0 to before 4.0.4 Fixed in 4.0.4 Patch available GHSA-v84m-gfw5-hm2w

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:apache:syncope:*:*:*:*:*:*:*:*3.0.0 to before 3.0.16; 4.0.0 to before 4.0.4VulnerableApache
  • cpe:2.3:a:apache:syncope:*:*:*:*:*:*:*:* Versions 3.0.0 to before 3.0.16; 4.0.0 to before 4.0.4 Vulnerable ·Apache

Remediation

  • Fix · GHSA-v84m-gfw5-hm2w org.apache.syncope.client.idrepo:syncope-client-idrepo-common-ui (Maven) Fixed in 3.0.16 Advisory →
  • Fix · GHSA-v84m-gfw5-hm2w org.apache.syncope.client.idrepo:syncope-client-idrepo-common-ui (Maven) Fixed in 4.0.4 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-23794
  2. 2026-10-03 Alias added: GHSA-v84m-gfw5-hm2w

References

  • TI-2025-35632 Apache Syncope: Remote Code Execution by delegated administrators CVSS 3.1HIGH 7.2
  • TI-2026-38503 Apache Syncope: Remote Code Execution via Scripted Connector CVSS 3.1CRITICAL 9.8
  • TI-2026-45025 Apache Syncope: RCE via Groovy Sandbox bypass CVSS 3.1CRITICAL 9.8
  • TI-2026-44406 Apache Syncope: User self-service privilege escalation CVSS 3.1CRITICAL 9.8
  • TI-2026-41245 Apache Syncope: SQL injection vulnerability in Audit Events search CVSS 3.1CRITICAL 9.8
  • TI-2026-38491 Apache Syncope: Remote Code Execution via Flowable BPMN Groovy ScriptTask CVSS 3.1CRITICAL 9.8
See all 23 →

Sources