Authentication bypass by capture-replay in PowerDNS Recursor
Priority LOW 30CWE-294Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · None · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-294.
Summary
Crafted zones can lead to increased incoming network traffic.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00462 40th percentileScored 2026-11-07
Fix Fixed Recursor (PowerDNS): 5.3.5, 5.2.8, 5.1.10
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| PowerDNS | Recursor | 5.3.0 to before 5.3.5; 5.2.0 to before 5.2.8; 5.1.0 to before 5.1.10 | 5.3.5, 5.2.8, 5.1.10 | Patch available | CNA |
- Recursor VendorPowerDNS Affected 5.3.0 to before 5.3.5; 5.2.0 to before 5.2.8; 5.1.0 to before 5.1.10 Fixed in 5.3.5, 5.2.8, 5.1.10 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:powerdns:recursor:*:*:*:*:*:*:*:* | 5.1.0 to before 5.1.10; 5.2.0 to before 5.2.8; 5.3.0 to before 5.3.5 | Vulnerable | PowerDNS |
- cpe:2.3:a:powerdns:recursor:*:*:*:*:*:*:*:* Versions 5.1.0 to before 5.1.10; 5.2.0 to before 5.2.8; 5.3.0 to before 5.3.5 Vulnerable ·PowerDNS
Remediation
- Fix · CNA Recursor (PowerDNS) Fixed in 5.3.5, 5.2.8, 5.1.10
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
PowerDNS Recursor 5.1.10, 5.2.8, 5.3.5
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2026-00260 Resource allocation without limits in PowerDNS RecursorPriority LOW 30
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2026-24027
- 2026-10-03 Alias added: GHSA-m7h2-p2wj-5964
References
More PowerDNS Recursor vulnerabilities
- TI-2023-27571 Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related… CVSS 3.1HIGH 7.5
- TI-2023-27773 The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance… CVSS 3.1HIGH 7.5
- TI-2015-01678 The label decompression functionality in PowerDNS Recursor 3.5.x, 3.6.x before 3.6.3, and… CVSS 2.0HIGH 7.8
- TI-2018-12065 Out-of-bounds read in [UNKNOWN] pdns-recursor CVSS 3.0HIGH 7.5
- TI-2017-11091 NULL pointer dereference in PowerDNS pdns-recursor CVSS 3.0HIGH 7.5
- TI-2014-07065 PowerDNS Recursor before 3.6.2 does not limit delegation chaining, which allows remote… CVSS 2.0MEDIUM 5.0
Sources
- CVE-2026-24027 · CVE Program
- CVE-2026-24027 · NVD
- FIRST EPSS
- GHSA-m7h2-p2wj-5964 · GitHub Advisory Database · CC BY 4.0
- CVE-2026-24027 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences