Craft has a potential authenticated Remote Code Execution via malicious attached Behavior
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub.
Summary
Craft is a platform for creating digital experiences. In versions 4.0.0-RC1 through 4.16.17 and 5.0.0-RC1 through 5.8.21, a Remote Code Execution (RCE) vulnerability exists in Craft CMS where the assembleLayoutFromPost() function in src/services/Fields.php fails to sanitize user-supplied configuration data before passing it to Craft::createObject(). This allows authenticated administrators to inject malicious Yii2 behavior configurations that execute arbitrary system commands on the server. This vulnerability represents an unpatched variant of the behavior injection vulnerability addressed in CVE-2025-68455, affecting different endpoints through a separate code path. This vulnerability is fixed in 5.8.22.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Craft CMS | cms | 5.0.0-RC1 to before 5.8.22; 4.0.0-RC1 to before 4.16.18 | 5.8.22, 4.16.18 | Patch available | CNA |
| — | craftcms/cms (Packagist) | 5.0.0-RC1 to before 5.8.22 | 5.8.22 | Patch available | GHSA-7jx7-3846-m7w7 |
| — | craftcms/cms (Packagist) | 4.0.0-RC1 to before 4.16.18 | 4.16.18 | Patch available | GHSA-7jx7-3846-m7w7 |
- cms VendorCraft CMS Affected 5.0.0-RC1 to before 5.8.22; 4.0.0-RC1 to before 4.16.18 Fixed in 5.8.22, 4.16.18 Patch available CNA
- craftcms/cms (Packagist) Vendor— Affected 5.0.0-RC1 to before 5.8.22 Fixed in 5.8.22 Patch available GHSA-7jx7-3846-m7w7
- craftcms/cms (Packagist) Vendor— Affected 4.0.0-RC1 to before 4.16.18 Fixed in 4.16.18 Patch available GHSA-7jx7-3846-m7w7
CPE configurations NVD · 7
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:craftcms:craft_cms:*:*:*:*:*:*:*:* | after 4.0.0, before 4.16.18; after 5.0.0, before 5.8.22 | Vulnerable | Craft CMS |
| cpe:2.3:a:craftcms:craft_cms:4.0.0:-:*:*:*:*:*:* | 4.0.0 | Vulnerable | Craft CMS |
| cpe:2.3:a:craftcms:craft_cms:4.0.0:rc1:*:*:*:*:*:* | 4.0.0 rc1 | Vulnerable | Craft CMS |
| cpe:2.3:a:craftcms:craft_cms:4.0.0:rc2:*:*:*:*:*:* | 4.0.0 rc2 | Vulnerable | Craft CMS |
| cpe:2.3:a:craftcms:craft_cms:4.0.0:rc3:*:*:*:*:*:* | 4.0.0 rc3 | Vulnerable | Craft CMS |
| cpe:2.3:a:craftcms:craft_cms:5.0.0:-:*:*:*:*:*:* | 5.0.0 | Vulnerable | Craft CMS |
| cpe:2.3:a:craftcms:craft_cms:5.0.0:rc1:*:*:*:*:*:* | 5.0.0 rc1 | Vulnerable | Craft CMS |
- cpe:2.3:a:craftcms:craft_cms:*:*:*:*:*:*:*:* Versions after 4.0.0, before 4.16.18; after 5.0.0, before 5.8.22 Vulnerable ·Craft CMS
- cpe:2.3:a:craftcms:craft_cms:4.0.0:-:*:*:*:*:*:* Versions 4.0.0 Vulnerable ·Craft CMS
- cpe:2.3:a:craftcms:craft_cms:4.0.0:rc1:*:*:*:*:*:* Versions 4.0.0 rc1 Vulnerable ·Craft CMS
- cpe:2.3:a:craftcms:craft_cms:4.0.0:rc2:*:*:*:*:*:* Versions 4.0.0 rc2 Vulnerable ·Craft CMS
- cpe:2.3:a:craftcms:craft_cms:4.0.0:rc3:*:*:*:*:*:* Versions 4.0.0 rc3 Vulnerable ·Craft CMS
- cpe:2.3:a:craftcms:craft_cms:5.0.0:-:*:*:*:*:*:* Versions 5.0.0 Vulnerable ·Craft CMS
- cpe:2.3:a:craftcms:craft_cms:5.0.0:rc1:*:*:*:*:*:* Versions 5.0.0 rc1 Vulnerable ·Craft CMS
Remediation
- Fix · CNA cms (craftcms) Fixed in 5.8.22, 4.16.18
- Fix · GHSA-7jx7-3846-m7w7 craftcms/cms (Packagist) Fixed in 5.8.22 Advisory →
- Fix · GHSA-7jx7-3846-m7w7 craftcms/cms (Packagist) Fixed in 4.16.18 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-25498
- 2026-10-03 Alias added: GHSA-7jx7-3846-m7w7
References
More Craft Cms vulnerabilities
- TI-2025-23503 Craft CMS Allows Remote Code Execution KEVCVSS 3.1CRITICAL 10.0
- TI-2024-37138 RCE when PHP `register_argc_argv` config setting is enabled in craftcms/cms KEVCVSS 4.0CRITICAL 9.3
- TI-2025-16994 Potential RCE with a compromised security key in craft/cms KEVCVSS 3.1HIGH 8.1
- TI-2025-24595 Craft CMS stores user-provided content in session files KEVCVSS 4.0MEDIUM 6.9
- TI-2023-22284 Craft CMS Remote Code Execution vulnerability CVSS 3.1CRITICAL 10.0
- TI-2024-25171 Craft CMS up to v3.7.31 was discovered to contain a SQL injection vulnerability via the GraphQL API endpoint. CVSS 3.1CRITICAL 9.8
Sources
- CVE-2026-25498 · CVE Program
- CVE-2026-25498 · NVD
- FIRST EPSS
- GHSA-7jx7-3846-m7w7 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences