Moodle: moodle: improper validation in file restore functionality leading to remote code execution
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-94.
Summary
A flaw was identified in Moodle’s backup restore functionality where specially crafted backup files were not properly validated during processing. If a malicious backup file is restored, it could lead to unintended execution of server-side code. Since restore capabilities are typically available to privileged users, exploitation requires authenticated access. Successful exploitation could result in full compromise of the Moodle server.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | moodle | before 4.5.9; 5.0.0 to before 5.0.5; 5.1.0 to before 5.1.2 | 4.5.9, 5.0.5, 5.1.2 | Patch available | CNA |
| — | moodle/moodle (Packagist) | 5.1.0-beta to before 5.1.2 | 5.1.2 | Patch available | GHSA-ggxq-2mg9-8966 |
| — | moodle/moodle (Packagist) | 5.0.0-beta to before 5.0.5 | 5.0.5 | Patch available | GHSA-ggxq-2mg9-8966 |
| — | moodle/moodle (Packagist) | before 4.5.9 | 4.5.9 | Patch available | GHSA-ggxq-2mg9-8966 |
- moodle Vendor— Affected before 4.5.9; 5.0.0 to before 5.0.5; 5.1.0 to before 5.1.2 Fixed in 4.5.9, 5.0.5, 5.1.2 Patch available CNA
- moodle/moodle (Packagist) Vendor— Affected 5.1.0-beta to before 5.1.2 Fixed in 5.1.2 Patch available GHSA-ggxq-2mg9-8966
- moodle/moodle (Packagist) Vendor— Affected 5.0.0-beta to before 5.0.5 Fixed in 5.0.5 Patch available GHSA-ggxq-2mg9-8966
- moodle/moodle (Packagist) Vendor— Affected before 4.5.9 Fixed in 4.5.9 Patch available GHSA-ggxq-2mg9-8966
Remediation
- Fix · CNA moodle Fixed in 4.5.9, 5.0.5, 5.1.2
- Fix · GHSA-ggxq-2mg9-8966 moodle/moodle (Packagist) Fixed in 5.1.2 Advisory →
- Fix · GHSA-ggxq-2mg9-8966 moodle/moodle (Packagist) Fixed in 5.0.5 Advisory →
- Fix · GHSA-ggxq-2mg9-8966 moodle/moodle (Packagist) Fixed in 4.5.9 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2026-26045
- 2026-10-03 Alias added: GHSA-ggxq-2mg9-8966
References
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2026-26045 · CVE Program
- CVE-2026-26045 · NVD
- FIRST EPSS
- GHSA-ggxq-2mg9-8966 · GitHub Advisory Database · CC BY 4.0
- CVE-2026-26045 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences