Read the docs
TI-2026-21052 Aliases CVE-2026-26047GHSA-cg8j-5cr2-568q

Moodle: moodle: uncontrolled resource consumption in tex formula editor leading to denial of service

Priority LOW 29CWE-400Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-400.

Summary

A denial-of-service vulnerability was identified in Moodle’s TeX formula editor. When rendering TeX content using mimetex, insufficient execution time limits could allow specially crafted formulas to consume excessive server resources. An authenticated user could abuse this behavior to degrade performance or cause service interruption.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00506 43rd percentileScored 2026-11-07
Fix Fixed moodle: 4.5.9, 5.0.5, 5.1.2moodle/moodle (Packagist): 5.1.2, 5.0.5, 4.5.9

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
—moodlebefore 4.5.9; 5.0.0 to before 5.0.5; 5.1.0 to before 5.1.24.5.9, 5.0.5, 5.1.2Patch availableCNA
—moodle/moodle (Packagist)5.1.0-beta to before 5.1.25.1.2Patch availableGHSA-cg8j-5cr2-568q
—moodle/moodle (Packagist)5.0.0-beta to before 5.0.55.0.5Patch availableGHSA-cg8j-5cr2-568q
—moodle/moodle (Packagist)before 4.5.94.5.9Patch availableGHSA-cg8j-5cr2-568q
  • moodle Vendor— Affected before 4.5.9; 5.0.0 to before 5.0.5; 5.1.0 to before 5.1.2 Fixed in 4.5.9, 5.0.5, 5.1.2 Patch available CNA
  • moodle/moodle (Packagist) Vendor— Affected 5.1.0-beta to before 5.1.2 Fixed in 5.1.2 Patch available GHSA-cg8j-5cr2-568q
  • moodle/moodle (Packagist) Vendor— Affected 5.0.0-beta to before 5.0.5 Fixed in 5.0.5 Patch available GHSA-cg8j-5cr2-568q
  • moodle/moodle (Packagist) Vendor— Affected before 4.5.9 Fixed in 4.5.9 Patch available GHSA-cg8j-5cr2-568q

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:*before 4.5.9; 5.0.0 to before 5.0.5; 5.1.0 to before 5.1.2VulnerableMoodle
  • cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions before 4.5.9; 5.0.0 to before 5.0.5; 5.1.0 to before 5.1.2 Vulnerable ·Moodle

Remediation

  • Fix · CNA moodle Fixed in 4.5.9, 5.0.5, 5.1.2
  • Fix · GHSA-cg8j-5cr2-568q moodle/moodle (Packagist) Fixed in 5.1.2 Advisory →
  • Fix · GHSA-cg8j-5cr2-568q moodle/moodle (Packagist) Fixed in 5.0.5 Advisory →
  • Fix · GHSA-cg8j-5cr2-568q moodle/moodle (Packagist) Fixed in 4.5.9 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-26047
  2. 2026-10-03 Alias added: GHSA-cg8j-5cr2-568q
  3. 2026-10-19 EPSS moved to the 50th–90th percentile
  4. 2026-10-25 EPSS moved to the below the 50th percentile

References

  • TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
  • TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
  • TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
  • TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
  • TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
  • TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
See all 636 →

Sources