GetSimpleCMS-CE < 3.3.22 Stored XSS via components.php
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
GetSimpleCMS Community Edition (CE) versions prior to 3.3.22 (3.3.16 tested) contains a stored cross-site scripting (XSS) vulnerability in the Theme to Components functionality within components.php. User-supplied input provided to the "slug" field of a component is stored without proper output encoding. While other fields are sanitized using safe_slash_html(), the slug parameter is written to XML and later rendered in the administrative interface without sanitation, resulting in persistent execution of arbitrary JavaScript. An authenticated administrator can inject malicious script content that executes whenever the affected Components page is viewed by any authenticated user, enabling session hijacking, unauthorized administrative actions, and persistent compromise of the CMS administrative interface.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GetSimpleCMS-CE | GetSimpleCMS-CE | 3.3.16 | 3.3.22 | Patch available | CNA |
- GetSimpleCMS-CE VendorGetSimpleCMS-CE Affected 3.3.16 Fixed in 3.3.22 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:getsimple-ce:getsimple_cms:*:*:*:*:community:*:*:* | 3.3.16 to before 3.3.22 | Vulnerable | GetSimpleCMS-CE |
- cpe:2.3:a:getsimple-ce:getsimple_cms:*:*:*:*:community:*:*:* Versions 3.3.16 to before 3.3.22 Vulnerable ·GetSimpleCMS-CE
Remediation
- Fix · CNA GetSimpleCMS-CE (GetSimpleCMS-CE) Fixed in 3.3.22
Timeline
- 2026-10-02 Threatist record created from CVE-2026-26351
- 2026-10-03 Alias added: GHSA-98hq-gxg8-fchj
References
More GetSimpleCMS-CE Getsimple Cms vulnerabilities
- TI-2024-36775 GetSimple CMS CE 3.3.19 suffers from arbitrary code execution in the template editing… CVSS 3.1CRITICAL 9.8
- TI-2025-30771 GetSimple CMS RCE in Edit component CVSS 4.0HIGH 8.6
- TI-2024-36777 GetSimple CMS CE 3.3.19 is vulnerable to Server-Side Request Forgery (SSRF) in the backend plugin module. CVSS 3.1HIGH 8.8
- TI-2026-21637 GetSimple CMS: Uploaded Files (feature) Arbitrary File Read Vulnerability CVSS 4.0HIGH 8.8
- TI-2026-21606 Unauthenticated Information Disclosure via .htaccess Reliance in Sensitive Directories CVSS 4.0HIGH 8.7
- TI-2024-36776 In the GetSimple CMS CE 3.3.19 management page, Server-Side Request Forgery (SSRF) can be… CVSS 3.1HIGH 7.2
Sources
- CVE-2026-26351 · CVE Program
- CVE-2026-26351 · NVD
- FIRST EPSS
- GHSA-98hq-gxg8-fchj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences