Craft affected by authenticated RCE via Twig SSTI - create() function + Symfony Process gadget
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-1336.
Summary
Craft is a content management system (CMS). There is an authenticated admin RCE in Craft CMS 5.8.21 via Server-Side Template Injection using the create() Twig function combined with a Symfony Process gadget chain. The create() Twig function exposes Craft::createObject(), which allows instantiation of arbitrary PHP classes with constructor arguments. Combined with the bundled symfony/process dependency, this enables RCE. This bypasses the fix implemented for CVE-2025-57811 (patched in 5.8.7). This vulnerability is fixed in 5.9.0-beta.1 and 4.17.0-beta.1.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Craft CMS | cms | 5.8.7 to before 5.9.0-beta.1; 4.0.0-RC1 to before 4.17.0-beta.1 | 5.9.0-beta.1, 4.17.0-beta.1 | Patch available | CNA |
| — | craftcms/cms (Packagist) | 5.8.7 to before 5.9.0-beta.1 | 5.9.0-beta.1 | Patch available | GHSA-94rc-cqvm-m4pw |
| — | craftcms/cms (Packagist) | 4.0.0-RC1 to before 4.17.0-beta.1 | 4.17.0-beta.1 | Patch available | GHSA-94rc-cqvm-m4pw |
- cms VendorCraft CMS Affected 5.8.7 to before 5.9.0-beta.1; 4.0.0-RC1 to before 4.17.0-beta.1 Fixed in 5.9.0-beta.1, 4.17.0-beta.1 Patch available CNA
- craftcms/cms (Packagist) Vendor— Affected 5.8.7 to before 5.9.0-beta.1 Fixed in 5.9.0-beta.1 Patch available GHSA-94rc-cqvm-m4pw
- craftcms/cms (Packagist) Vendor— Affected 4.0.0-RC1 to before 4.17.0-beta.1 Fixed in 4.17.0-beta.1 Patch available GHSA-94rc-cqvm-m4pw
CPE configurations NVD · 7
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:craftcms:craft_cms:*:*:*:*:*:*:*:* | after 4.0.0, before 4.17.0; after 5.0.0, before 5.9.0 | Vulnerable | Craft CMS |
| cpe:2.3:a:craftcms:craft_cms:4.0.0:-:*:*:*:*:*:* | 4.0.0 | Vulnerable | Craft CMS |
| cpe:2.3:a:craftcms:craft_cms:4.0.0:rc1:*:*:*:*:*:* | 4.0.0 rc1 | Vulnerable | Craft CMS |
| cpe:2.3:a:craftcms:craft_cms:4.0.0:rc2:*:*:*:*:*:* | 4.0.0 rc2 | Vulnerable | Craft CMS |
| cpe:2.3:a:craftcms:craft_cms:4.0.0:rc3:*:*:*:*:*:* | 4.0.0 rc3 | Vulnerable | Craft CMS |
| cpe:2.3:a:craftcms:craft_cms:5.0.0:-:*:*:*:*:*:* | 5.0.0 | Vulnerable | Craft CMS |
| cpe:2.3:a:craftcms:craft_cms:5.0.0:rc1:*:*:*:*:*:* | 5.0.0 rc1 | Vulnerable | Craft CMS |
- cpe:2.3:a:craftcms:craft_cms:*:*:*:*:*:*:*:* Versions after 4.0.0, before 4.17.0; after 5.0.0, before 5.9.0 Vulnerable ·Craft CMS
- cpe:2.3:a:craftcms:craft_cms:4.0.0:-:*:*:*:*:*:* Versions 4.0.0 Vulnerable ·Craft CMS
- cpe:2.3:a:craftcms:craft_cms:4.0.0:rc1:*:*:*:*:*:* Versions 4.0.0 rc1 Vulnerable ·Craft CMS
- cpe:2.3:a:craftcms:craft_cms:4.0.0:rc2:*:*:*:*:*:* Versions 4.0.0 rc2 Vulnerable ·Craft CMS
- cpe:2.3:a:craftcms:craft_cms:4.0.0:rc3:*:*:*:*:*:* Versions 4.0.0 rc3 Vulnerable ·Craft CMS
- cpe:2.3:a:craftcms:craft_cms:5.0.0:-:*:*:*:*:*:* Versions 5.0.0 Vulnerable ·Craft CMS
- cpe:2.3:a:craftcms:craft_cms:5.0.0:rc1:*:*:*:*:*:* Versions 5.0.0 rc1 Vulnerable ·Craft CMS
Remediation
- Fix · CNA cms (craftcms) Fixed in 5.9.0-beta.1, 4.17.0-beta.1
- Fix · GHSA-94rc-cqvm-m4pw craftcms/cms (Packagist) Fixed in 5.9.0-beta.1 Advisory →
- Fix · GHSA-94rc-cqvm-m4pw craftcms/cms (Packagist) Fixed in 4.17.0-beta.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-28695
- 2026-10-03 Alias added: GHSA-94rc-cqvm-m4pw
- 2026-10-21 EPSS moved to the 50th–90th percentile
- 2026-10-25 EPSS moved to the below the 50th percentile
- 2026-10-30 EPSS moved to the 50th–90th percentile
References
More Craft Cms vulnerabilities
- TI-2025-23503 Craft CMS Allows Remote Code Execution KEVCVSS 3.1CRITICAL 10.0
- TI-2024-37138 RCE when PHP `register_argc_argv` config setting is enabled in craftcms/cms KEVCVSS 4.0CRITICAL 9.3
- TI-2025-16994 Potential RCE with a compromised security key in craft/cms KEVCVSS 3.1HIGH 8.1
- TI-2025-24595 Craft CMS stores user-provided content in session files KEVCVSS 4.0MEDIUM 6.9
- TI-2023-22284 Craft CMS Remote Code Execution vulnerability CVSS 3.1CRITICAL 10.0
- TI-2024-25171 Craft CMS up to v3.7.31 was discovered to contain a SQL injection vulnerability via the GraphQL API endpoint. CVSS 3.1CRITICAL 9.8
Sources
- CVE-2026-28695 · CVE Program
- CVE-2026-28695 · NVD
- FIRST EPSS
- GHSA-94rc-cqvm-m4pw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences