Read the docs
TI-2026-23316 Aliases CVE-2026-29199GHSA-7gm6-w7mx-58cr

Weak password recovery in phpBB

Priority LOW 37CWE-640Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
High · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-640.

Summary

phpBB before 3.3.16 is vulnerable to Host Header Injection that can lead to password rest link poisoning. When force_server_vars is disabled, the servers hostname may be extracted from the HTTP Host header which is used to generate the password reset link URL. An attacker who can manipulate the Host header (e.g. through misconfigured host setup or missing header validation by the webserver) can cause password reset emails to contain a link pointing to an attacker-controlled domain, potentially leading to account takeover.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00249 16th percentileScored 2026-11-07
Fix Fixed phpbb/phpbb (Packagist): 3.3.16, 4.0.0-a2

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
phpBBphpBB3.0.0 – 3.3.15—No fix listedCNA
—phpbb/phpbb (Packagist)3.0.0 to before 3.3.163.3.16Patch availableGHSA-7gm6-w7mx-58cr
—phpbb/phpbb (Packagist)4.0.0-a1 to before 4.0.0-a24.0.0-a2Patch availableGHSA-7gm6-w7mx-58cr
  • phpBB VendorphpBB Affected 3.0.0 – 3.3.15 Fixed in — No fix listed CNA
  • phpbb/phpbb (Packagist) Vendor— Affected 3.0.0 to before 3.3.16 Fixed in 3.3.16 Patch available GHSA-7gm6-w7mx-58cr
  • phpbb/phpbb (Packagist) Vendor— Affected 4.0.0-a1 to before 4.0.0-a2 Fixed in 4.0.0-a2 Patch available GHSA-7gm6-w7mx-58cr

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:phpbb:phpbb:*:*:*:*:*:*:*:*before 3.3.16VulnerablephpBB
  • cpe:2.3:a:phpbb:phpbb:*:*:*:*:*:*:*:* Versions before 3.3.16 Vulnerable ·phpBB

Remediation

  • Fix · GHSA-7gm6-w7mx-58cr phpbb/phpbb (Packagist) Fixed in 3.3.16 Advisory →
  • Fix · GHSA-7gm6-w7mx-58cr phpbb/phpbb (Packagist) Fixed in 4.0.0-a2 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-29199
  2. 2026-10-03 Alias added: GHSA-7gm6-w7mx-58cr

References

  • TI-2025-43137 Cross Site Request Forgery vulnerability in Phpbb phbb3 v.3.3.15 allows a local attacker… CVSS 3.1HIGH 8.8
  • TI-2001-01423 prefs.php in phpBB 1.4.0 and earlier allows remote authenticated users to execute… CVSS 3.1HIGH 8.8
  • TI-2008-03086 Unspecified vulnerability in phpBB before 3.0.1 has unknown impact and attack vectors… CVSS 2.0HIGH 10.0
  • TI-2008-01694 Multiple unspecified vulnerabilities in phpBB before 3.0.1 have unknown impact and attack… CVSS 2.0HIGH 10.0
  • TI-2006-06909 PHP remote file inclusion vulnerability in includes/not_mem.php in the Add Name module… CVSS 2.0HIGH 7.5
  • TI-2019-12678 In phpBB before 3.1.7-PL1, includes/acp/acp_bbcodes.php has improper verification of a… CVSS 3.1HIGH 8.8
See all 37 →

Sources