CraftCMS's `ElementSearchController` Affected by Blind SQL Injection
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-89.
Summary
Craft is a content management system (CMS). The ElementSearchController::actionSearch() endpoint is missing the unset() protection that was added to ElementIndexesController in CVE-2026-25495. The exact same SQL injection vulnerability (including criteria[orderBy], the original advisory vector) works on this controller because the fix was never applied to it. Any authenticated control panel user (no admin required) can inject arbitrary SQL via criteria[where], criteria[orderBy], or other query properties, and extract the full database contents via boolean-based blind injection. Users should update to the patched 5.9.9 release to mitigate the issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Craft CMS | cms | 5.0.0-RC1 – 5.9.8 | — | No fix listed | CNA |
| — | craftcms/cms (Packagist) | 5.0.0-RC1 to before 5.9.9 | 5.9.9 | Patch available | GHSA-g7j6-fmwx-7vp8 |
- cms VendorCraft CMS Affected 5.0.0-RC1 – 5.9.8 Fixed in — No fix listed CNA
- craftcms/cms (Packagist) Vendor— Affected 5.0.0-RC1 to before 5.9.9 Fixed in 5.9.9 Patch available GHSA-g7j6-fmwx-7vp8
Remediation
- Fix · GHSA-g7j6-fmwx-7vp8 craftcms/cms (Packagist) Fixed in 5.9.9 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-31858
- 2026-10-03 Alias added: GHSA-g7j6-fmwx-7vp8
References
Patch 2
More Craft Cms vulnerabilities
- TI-2025-23503 Craft CMS Allows Remote Code Execution KEVCVSS 3.1CRITICAL 10.0
- TI-2024-37138 RCE when PHP `register_argc_argv` config setting is enabled in craftcms/cms KEVCVSS 4.0CRITICAL 9.3
- TI-2025-16994 Potential RCE with a compromised security key in craft/cms KEVCVSS 3.1HIGH 8.1
- TI-2025-24595 Craft CMS stores user-provided content in session files KEVCVSS 4.0MEDIUM 6.9
- TI-2023-22284 Craft CMS Remote Code Execution vulnerability CVSS 3.1CRITICAL 10.0
- TI-2024-25171 Craft CMS up to v3.7.31 was discovered to contain a SQL injection vulnerability via the GraphQL API endpoint. CVSS 3.1CRITICAL 9.8
Sources
- CVE-2026-31858 · CVE Program
- CVE-2026-31858 · NVD
- FIRST EPSS
- GHSA-g7j6-fmwx-7vp8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences