Read the docs
TI-2026-24439 Aliases CVE-2026-31887GHSA-7vvp-j573-5584

Shopware unauthenticated data extraction possible through store-api.order endpoint

Priority LOW 38CWE-863Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Attack requirements
Present
Impact type
Security bypass
Confidentiality · integrity · availability
High · None · None
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-863.

Summary

Shopware is an open commerce platform. Prior to 6.7.8.1 and 6.6.10.15, an insufficient check on the filter types for unauthenticated customers allows access to orders of other customers. This is part of the deepLinkCode support on the store-api.order endpoint. This vulnerability is fixed in 6.7.8.1 and 6.6.10.15.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00272 19th percentileScored 2026-11-07
Fix Fixed core (shopware): 6.7.8.1, 6.6.10.15platform (shopware): 6.7.8.1, 6.6.10.15+2 more products

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
shopwarecore6.7.0.0 to before 6.7.8.1; before 6.6.10.156.7.8.1, 6.6.10.15Patch availableCNA
shopwareplatform6.7.0.0 to before 6.7.8.1; before 6.6.10.156.7.8.1, 6.6.10.15Patch availableCNA
—shopware/core (Packagist)6.7.0.0 to before 6.7.8.16.7.8.1Patch availableGHSA-7vvp-j573-5584
—shopware/core (Packagist)before 6.6.10.156.6.10.15Patch availableGHSA-7vvp-j573-5584
—shopware/platform (Packagist)6.7.0.0 to before 6.7.8.16.7.8.1Patch availableGHSA-7vvp-j573-5584
—shopware/platform (Packagist)before 6.6.10.156.6.10.15Patch availableGHSA-7vvp-j573-5584
  • core Vendorshopware Affected 6.7.0.0 to before 6.7.8.1; before 6.6.10.15 Fixed in 6.7.8.1, 6.6.10.15 Patch available CNA
  • platform Vendorshopware Affected 6.7.0.0 to before 6.7.8.1; before 6.6.10.15 Fixed in 6.7.8.1, 6.6.10.15 Patch available CNA
  • shopware/core (Packagist) Vendor— Affected 6.7.0.0 to before 6.7.8.1 Fixed in 6.7.8.1 Patch available GHSA-7vvp-j573-5584
  • shopware/core (Packagist) Vendor— Affected before 6.6.10.15 Fixed in 6.6.10.15 Patch available GHSA-7vvp-j573-5584
  • shopware/platform (Packagist) Vendor— Affected 6.7.0.0 to before 6.7.8.1 Fixed in 6.7.8.1 Patch available GHSA-7vvp-j573-5584
  • shopware/platform (Packagist) Vendor— Affected before 6.6.10.15 Fixed in 6.6.10.15 Patch available GHSA-7vvp-j573-5584

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:shopware:shopware:*:*:*:*:*:*:*:*before 6.6.10.15; 6.7.0.0 to before 6.7.8.1Vulnerableshopware
  • cpe:2.3:a:shopware:shopware:*:*:*:*:*:*:*:* Versions before 6.6.10.15; 6.7.0.0 to before 6.7.8.1 Vulnerable ·shopware

Remediation

  • Fix · CNA core (shopware) Fixed in 6.7.8.1, 6.6.10.15
  • Fix · CNA platform (shopware) Fixed in 6.7.8.1, 6.6.10.15
  • Fix · GHSA-7vvp-j573-5584 shopware/core (Packagist) Fixed in 6.7.8.1 Advisory →
  • Fix · GHSA-7vvp-j573-5584 shopware/core (Packagist) Fixed in 6.6.10.15 Advisory →
  • Fix · GHSA-7vvp-j573-5584 shopware/platform (Packagist) Fixed in 6.7.8.1 Advisory →
  • Fix · GHSA-7vvp-j573-5584 shopware/platform (Packagist) Fixed in 6.6.10.15 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-31887
  2. 2026-10-03 Alias added: GHSA-7vvp-j573-5584

References

  • TI-2023-01895 Improper Control of Generation of Code in Twig Rendered Views in Shopware CVSS 3.1HIGH 8.8
  • TI-2025-20623 Shopware prior to version 6.5.8.13 is affected by a SQL injection vulnerability in the… CVSS 3.1MEDIUM 6.8
  • TI-2024-28343 Shopware vulnerable to Server Side Template Injection in Twig using Context functions CVSS 3.1HIGH 8.3
  • TI-2019-09582 In createInstanceFromNamedArguments in Shopware through 5.6.x, a crafted web request can… CVSS 3.1HIGH 8.8
  • TI-2016-02607 The backend/Login/load/ script in Shopware before 5.1.5 allows remote attackers to execute arbitrary code. CVSS 3.0CRITICAL 9.8
  • TI-2025-32365 A stored cross-site scripting (XSS) vulnerability exists in the Shopware 6 installation… CVSS 3.1MEDIUM 6.1
See all 66 →

Sources