Read the docs
TI-2026-24801 Aliases CVE-2026-32272GHSA-r54v-qq87-px5r

Craft Commerce: Blind SQL Injection via hasVariant/hasProduct

Priority LOW 39CWE-89Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Attack requirements
None
Impact type
SQL injection
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-89.

Summary

Craft Commerce is an ecommerce platform for Craft CMS. In versions 5.0.0 through 5.5.4, an SQL injection vulnerability exists where the ProductQuery::hasVariant and VariantQuery::hasProduct properties bypass the input sanitization blocklist added to ElementIndexesController in a prior security fix (GHSA-2453-mppf-46cj). The blocklist only strips top-level Yii2 Query properties such as where and orderBy, but hasVariant and hasProduct pass through untouched and internally call Craft::configure() on a subquery without sanitization, re-introducing SQL injection. Any authenticated control panel user can exploit this via boolean-based blind SQL injection to extract arbitrary database contents, including security keys that enable forging admin sessions for privilege escalation. This issue has been fixed in version 5.6.0.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00304 23rd percentileScored 2026-11-07
Fix Fixed craftcms/commerce (Packagist): 5.6.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
Craft CMScommerce>= 5.0.0 < 5.6.0—No fix listedCNA
—craftcms/commerce (Packagist)5.0.0 to before 5.6.05.6.0Patch availableGHSA-r54v-qq87-px5r
  • commerce VendorCraft CMS Affected >= 5.0.0 < 5.6.0 Fixed in — No fix listed CNA
  • craftcms/commerce (Packagist) Vendor— Affected 5.0.0 to before 5.6.0 Fixed in 5.6.0 Patch available GHSA-r54v-qq87-px5r

CPE names Threatist (inferred) · 1

Inferred from how NVD named this product before; not given by a source.

CPEVersionsRoleVendor
cpe:2.3:a:craftcms:craft_commerce:*:*:*:*:*:*:*:*——Craft CMS
  • cpe:2.3:a:craftcms:craft_commerce:*:*:*:*:*:*:*:* Versions — — ·Craft CMS

Remediation

  • Fix · GHSA-r54v-qq87-px5r craftcms/commerce (Packagist) Fixed in 5.6.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-32272
  2. 2026-10-03 Alias added: GHSA-r54v-qq87-px5r
  3. 2026-10-25 Priority changed: MEDIUM → LOW

References

  • TI-2025-23503 Craft CMS Allows Remote Code Execution KEVCVSS 3.1CRITICAL 10.0
  • TI-2024-37138 RCE when PHP `register_argc_argv` config setting is enabled in craftcms/cms KEVCVSS 4.0CRITICAL 9.3
  • TI-2025-16994 Potential RCE with a compromised security key in craft/cms KEVCVSS 3.1HIGH 8.1
  • TI-2025-24595 Craft CMS stores user-provided content in session files KEVCVSS 4.0MEDIUM 6.9
  • TI-2023-22284 Craft CMS Remote Code Execution vulnerability CVSS 3.1CRITICAL 10.0
  • TI-2024-25171 Craft CMS up to v3.7.31 was discovered to contain a SQL injection vulnerability via the GraphQL API endpoint. CVSS 3.1CRITICAL 9.8
See all 203 →

Sources