Craft CMS: Low-privilege users could read private asset contents when editing an asset (IDOR)
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-639.
Summary
Craft CMS is a content management system (CMS). From version 4.0.0-RC1 to before version 4.17.8 and from version 5.0.0-RC1 to before version 5.9.14, a low-privileged authenticated user can read private asset content by calling assets/edit-image with an arbitrary assetId that they are not authorized to view. The endpoint returns image bytes (or a preview redirect) without enforcing a per-asset view authorization check, leading to potential unauthorized disclosure of private files. This issue has been patched in versions 4.17.8 and 5.9.14.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Craft CMS | cms | 4.0.0-RC1 to before 4.17.8; 5.0.0-RC1 to before 5.9.14 | 4.17.8, 5.9.14 | Patch available | CNA |
| — | craftcms/cms (Packagist) | 4.0.0-RC1 to before 4.17.8 | 4.17.8 | Patch available | GHSA-3pvf-vxrv-hh9c |
| — | craftcms/cms (Packagist) | 5.0.0-RC1 to before 5.9.14 | 5.9.14 | Patch available | GHSA-3pvf-vxrv-hh9c |
- cms VendorCraft CMS Affected 4.0.0-RC1 to before 4.17.8; 5.0.0-RC1 to before 5.9.14 Fixed in 4.17.8, 5.9.14 Patch available CNA
- craftcms/cms (Packagist) Vendor— Affected 4.0.0-RC1 to before 4.17.8 Fixed in 4.17.8 Patch available GHSA-3pvf-vxrv-hh9c
- craftcms/cms (Packagist) Vendor— Affected 5.0.0-RC1 to before 5.9.14 Fixed in 5.9.14 Patch available GHSA-3pvf-vxrv-hh9c
CPE configurations NVD · 7
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:craftcms:craft_cms:*:*:*:*:*:*:*:* | after 4.0.0, before 4.17.8; after 5.0.0, before 5.9.14 | Vulnerable | Craft CMS |
| cpe:2.3:a:craftcms:craft_cms:4.0.0:-:*:*:*:*:*:* | 4.0.0 | Vulnerable | Craft CMS |
| cpe:2.3:a:craftcms:craft_cms:4.0.0:rc1:*:*:*:*:*:* | 4.0.0 rc1 | Vulnerable | Craft CMS |
| cpe:2.3:a:craftcms:craft_cms:4.0.0:rc2:*:*:*:*:*:* | 4.0.0 rc2 | Vulnerable | Craft CMS |
| cpe:2.3:a:craftcms:craft_cms:4.0.0:rc3:*:*:*:*:*:* | 4.0.0 rc3 | Vulnerable | Craft CMS |
| cpe:2.3:a:craftcms:craft_cms:5.0.0:-:*:*:*:*:*:* | 5.0.0 | Vulnerable | Craft CMS |
| cpe:2.3:a:craftcms:craft_cms:5.0.0:rc1:*:*:*:*:*:* | 5.0.0 rc1 | Vulnerable | Craft CMS |
- cpe:2.3:a:craftcms:craft_cms:*:*:*:*:*:*:*:* Versions after 4.0.0, before 4.17.8; after 5.0.0, before 5.9.14 Vulnerable ·Craft CMS
- cpe:2.3:a:craftcms:craft_cms:4.0.0:-:*:*:*:*:*:* Versions 4.0.0 Vulnerable ·Craft CMS
- cpe:2.3:a:craftcms:craft_cms:4.0.0:rc1:*:*:*:*:*:* Versions 4.0.0 rc1 Vulnerable ·Craft CMS
- cpe:2.3:a:craftcms:craft_cms:4.0.0:rc2:*:*:*:*:*:* Versions 4.0.0 rc2 Vulnerable ·Craft CMS
- cpe:2.3:a:craftcms:craft_cms:4.0.0:rc3:*:*:*:*:*:* Versions 4.0.0 rc3 Vulnerable ·Craft CMS
- cpe:2.3:a:craftcms:craft_cms:5.0.0:-:*:*:*:*:*:* Versions 5.0.0 Vulnerable ·Craft CMS
- cpe:2.3:a:craftcms:craft_cms:5.0.0:rc1:*:*:*:*:*:* Versions 5.0.0 rc1 Vulnerable ·Craft CMS
Remediation
- Fix · CNA cms (craftcms) Fixed in 4.17.8, 5.9.14
- Fix · GHSA-3pvf-vxrv-hh9c craftcms/cms (Packagist) Fixed in 4.17.8 Advisory →
- Fix · GHSA-3pvf-vxrv-hh9c craftcms/cms (Packagist) Fixed in 5.9.14 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-33158
- 2026-10-03 Alias added: GHSA-3pvf-vxrv-hh9c
References
Advisory 2
More Craft Cms vulnerabilities
- TI-2025-23503 Craft CMS Allows Remote Code Execution KEVCVSS 3.1CRITICAL 10.0
- TI-2024-37138 RCE when PHP `register_argc_argv` config setting is enabled in craftcms/cms KEVCVSS 4.0CRITICAL 9.3
- TI-2025-16994 Potential RCE with a compromised security key in craft/cms KEVCVSS 3.1HIGH 8.1
- TI-2025-24595 Craft CMS stores user-provided content in session files KEVCVSS 4.0MEDIUM 6.9
- TI-2023-22284 Craft CMS Remote Code Execution vulnerability CVSS 3.1CRITICAL 10.0
- TI-2024-25171 Craft CMS up to v3.7.31 was discovered to contain a SQL injection vulnerability via the GraphQL API endpoint. CVSS 3.1CRITICAL 9.8
Sources
- CVE-2026-33158 · CVE Program
- CVE-2026-33158 · NVD
- FIRST EPSS
- GHSA-3pvf-vxrv-hh9c · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences