Read the docs
TI-2026-25673 Aliases CVE-2026-33256GHSA-f4c2-g8rq-pq9h

Unbounded memory allocation by internal web server

Priority MEDIUM 40CWE-770Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-770.

Summary

An attacker can send a web request that causes unlimited memory allocation in the internal web server, leading to a denial of service. The internal web server is disabled by default.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00606 49th percentileScored 2026-11-07
Fix Fixed Recursor (PowerDNS): 5.4.1, 5.3.6, 5.2.9

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
PowerDNSRecursor5.4.0 to before 5.4.1; 5.3.0 to before 5.3.6; 5.2.0 to before 5.2.95.4.1, 5.3.6, 5.2.9Patch availableCNA
  • Recursor VendorPowerDNS Affected 5.4.0 to before 5.4.1; 5.3.0 to before 5.3.6; 5.2.0 to before 5.2.9 Fixed in 5.4.1, 5.3.6, 5.2.9 Patch available CNA

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:powerdns:recursor:*:*:*:*:*:*:*:*5.2.0 to before 5.2.9; 5.3.0 to before 5.3.6VulnerablePowerDNS
cpe:2.3:a:powerdns:recursor:5.4.0:*:*:*:*:*:*:*5.4.0VulnerablePowerDNS
  • cpe:2.3:a:powerdns:recursor:*:*:*:*:*:*:*:* Versions 5.2.0 to before 5.2.9; 5.3.0 to before 5.3.6 Vulnerable ·PowerDNS
  • cpe:2.3:a:powerdns:recursor:5.4.0:*:*:*:*:*:*:* Versions 5.4.0 Vulnerable ·PowerDNS

Remediation

  • Fix · CNA Recursor (PowerDNS) Fixed in 5.4.1, 5.3.6, 5.2.9

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    PowerDNS Recursor 5.2.9, 5.3.6, 5.4.1

    9 records Highest priority Priority MEDIUM 2 MEDIUM, 7 LOW

    Other records, highest priority first

    • TI-2026-25675 Crafted zones can cause increased resource usagePriority MEDIUM 40
    • TI-2026-25677 Insufficient input validation of internal webserverPriority LOW 39
    • TI-2026-25674 Insufficient input validation of internal webserverPriority LOW 39

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-33256
  2. 2026-10-03 Alias added: GHSA-f4c2-g8rq-pq9h
  3. 2026-10-25 EPSS moved to the below the 50th percentile

References

  • TI-2023-27571 Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related… CVSS 3.1HIGH 7.5
  • TI-2023-27773 The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance… CVSS 3.1HIGH 7.5
  • TI-2015-01678 The label decompression functionality in PowerDNS Recursor 3.5.x, 3.6.x before 3.6.3, and… CVSS 2.0HIGH 7.8
  • TI-2018-12065 Out-of-bounds read in [UNKNOWN] pdns-recursor CVSS 3.0HIGH 7.5
  • TI-2017-11091 NULL pointer dereference in PowerDNS pdns-recursor CVSS 3.0HIGH 7.5
  • TI-2014-07065 PowerDNS Recursor before 3.6.2 does not limit delegation chaining, which allows remote… CVSS 2.0MEDIUM 5.0
See all 49 →

Sources