Apache Kafka, Apache Kafka Clients: Information Exposure Through Network Client Log Output
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-532.
Summary
Information exposure vulnerability has been identified in Apache Kafka. The NetworkClient component will output entire requests and responses information in the DEBUG log level in the logs. By default, the log level is set to INFO level. If the DEBUG level is enabled, the sensitive information will be exposed via the requests and responses output log. The entire lists of impacted requests and responses are: * AlterConfigsRequest * AlterUserScramCredentialsRequest * ExpireDelegationTokenRequest * IncrementalAlterConfigsRequest * RenewDelegationTokenRequest * SaslAuthenticateRequest * createDelegationTokenResponse * describeDelegationTokenResponse * SaslAuthenticateResponse This issue affects Apache Kafka: from any version supported the listed API above through v3.9.1, v4.0.0. We advise the Kafka users to upgrade to v3.9.2, v4.0.1, or later to avoid this vulnerability.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Kafka | 0.11.0 – 3.9.1; 4.0.0 | — | No fix listed | CNA |
| Apache | Apache Kafka Clients | 0.11.0 – 3.9.1; 4.0.0 | — | No fix listed | CNA |
| — | org.apache.kafka:kafka-clients (Maven) | 0.11.0 to before 3.9.2 | 3.9.2 | Patch available | GHSA-wf66-mphr-4c4r |
| — | org.apache.kafka:kafka-clients (Maven) | 4.0.0 to before 4.0.1 | 4.0.1 | Patch available | GHSA-wf66-mphr-4c4r |
- Apache Kafka VendorApache Affected 0.11.0 – 3.9.1; 4.0.0 Fixed in — No fix listed CNA
- Apache Kafka Clients VendorApache Affected 0.11.0 – 3.9.1; 4.0.0 Fixed in — No fix listed CNA
- org.apache.kafka:kafka-clients (Maven) Vendor— Affected 0.11.0 to before 3.9.2 Fixed in 3.9.2 Patch available GHSA-wf66-mphr-4c4r
- org.apache.kafka:kafka-clients (Maven) Vendor— Affected 4.0.0 to before 4.0.1 Fixed in 4.0.1 Patch available GHSA-wf66-mphr-4c4r
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:kafka:*:*:*:*:*:*:*:* | 0.11.0.0 to before 3.9.2 | Vulnerable | Apache |
| cpe:2.3:a:apache:kafka:4.0.0:-:*:*:*:*:*:* | 4.0.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:kafka:4.0.0:rc0:*:*:*:*:*:* | 4.0.0 rc0 | Vulnerable | Apache |
| cpe:2.3:a:apache:kafka:4.0.0:rc1:*:*:*:*:*:* | 4.0.0 rc1 | Vulnerable | Apache |
| cpe:2.3:a:apache:kafka:4.0.0:rc3:*:*:*:*:*:* | 4.0.0 rc3 | Vulnerable | Apache |
- cpe:2.3:a:apache:kafka:*:*:*:*:*:*:*:* Versions 0.11.0.0 to before 3.9.2 Vulnerable ·Apache
- cpe:2.3:a:apache:kafka:4.0.0:-:*:*:*:*:*:* Versions 4.0.0 Vulnerable ·Apache
- cpe:2.3:a:apache:kafka:4.0.0:rc0:*:*:*:*:*:* Versions 4.0.0 rc0 Vulnerable ·Apache
- cpe:2.3:a:apache:kafka:4.0.0:rc1:*:*:*:*:*:* Versions 4.0.0 rc1 Vulnerable ·Apache
- cpe:2.3:a:apache:kafka:4.0.0:rc3:*:*:*:*:*:* Versions 4.0.0 rc3 Vulnerable ·Apache
Remediation
- Fix · GHSA-wf66-mphr-4c4r org.apache.kafka:kafka-clients (Maven) Fixed in 3.9.2 Advisory →
- Fix · GHSA-wf66-mphr-4c4r org.apache.kafka:kafka-clients (Maven) Fixed in 4.0.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-33558
- 2026-10-03 Alias added: GHSA-wf66-mphr-4c4r
- 2026-10-25 EPSS moved to the below the 50th percentile
- 2026-10-27 EPSS moved to the 50th–90th percentile
References
More Apache Kafka vulnerabilities
- TI-2025-20589 Apache Kafka Client: Arbitrary file read and SSRF vulnerability CVSS 3.1HIGH 7.5
- TI-2026-25947 Apache Kafka: Missing JWT token validation in OAUTHBEARER authentication CVSS 3.1CRITICAL 9.1
- TI-2018-12295 Improper input validation in Apache Kafka CVSS 3.0HIGH 8.8
- TI-2025-20590 Apache Kafka: Possible RCE attack via SASL JAAS LdapLoginModule configuration CVSS 3.1HIGH 8.8
- TI-2022-15706 Unauthenticated clients may cause OutOfMemoryError on Apache Kafka Brokers CVSS 3.1HIGH 7.5
- TI-2025-20591 Apache Kafka: Possible RCE/Denial of service attack via SASL JAAS JndiLoginModule configuration CVSS 3.1HIGH 7.5
Sources
- CVE-2026-33558 · CVE Program
- CVE-2026-33558 · NVD
- FIRST EPSS
- GHSA-wf66-mphr-4c4r · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences