Read the docs
TI-2026-26176 Aliases CVE-2026-33804GHSA-v9ww-2j6r-98q6

@fastify/middie vulnerable to middleware bypass via deprecated ignoreDuplicateSlashes option

Priority MEDIUM 41CWE-436Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.

Summary

@fastify/middie versions 9.3.1 and earlier are vulnerable to middleware bypass when the deprecated Fastify ignoreDuplicateSlashes option is enabled. The middleware path matching logic does not account for duplicate slash normalization performed by Fastify's router, allowing requests with duplicate slashes to bypass middleware authentication and authorization checks. This only affects applications using the deprecated ignoreDuplicateSlashes option. Upgrade to @fastify/middie 9.3.2 to fix this issue. There are no workarounds other than disabling the ignoreDuplicateSlashes option.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00278 20th percentileScored 2026-11-07
Fix Fixed @fastify/middie (@fastify/middie): 9.3.2@fastify/middie (npm): 9.3.2

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
fastify@fastify/middiebefore 9.3.29.3.2Patch availableCNA
—@fastify/middie (npm)before 9.3.29.3.2Patch availableGHSA-v9ww-2j6r-98q6
  • @fastify/middie Vendorfastify Affected before 9.3.2 Fixed in 9.3.2 Patch available CNA
  • @fastify/middie (npm) Vendor— Affected before 9.3.2 Fixed in 9.3.2 Patch available GHSA-v9ww-2j6r-98q6

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:fastify:fastify\/middie:*:*:*:*:*:node.js:*:*before 9.3.2Vulnerablefastify
  • cpe:2.3:a:fastify:fastify\/middie:*:*:*:*:*:node.js:*:* Versions before 9.3.2 Vulnerable ·fastify

Remediation

  • Fix · CNA @fastify/middie (@fastify/middie) Fixed in 9.3.2
  • Fix · GHSA-v9ww-2j6r-98q6 @fastify/middie (npm) Fixed in 9.3.2 Advisory →

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    @fastify/middie 9.3.2

    2 records Highest priority Priority HIGH 1 HIGH, 1 MEDIUM

    Other records, highest priority first

    • TI-2026-05498 @fastify/middie vulnerable to middleware authentication bypass in child plugin scopesPriority HIGH 74

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-33804
  2. 2026-10-03 Alias added: GHSA-v9ww-2j6r-98q6

References

  • TI-2026-05498 @fastify/middie vulnerable to middleware authentication bypass in child plugin scopes CVSS 3.1CRITICAL 9.1
  • TI-2026-17725 Fastify Middie Middleware Path Bypass CVSS 3.1HIGH 8.8
  • TI-2026-58517 @fastify/middie vulnerable to path-scoped middleware bypass via absolute-form request target CVSS 3.1CRITICAL 9.1
  • TI-2026-12029 @fastify/middie vulnerable to authorization bypass via encoded slash in path parameter values CVSS 3.1CRITICAL 9.1
  • TI-2026-12013 @fastify/middie standalone engine vulnerable to Denial of Service via malformed percent-encoded paths CVSS 3.1HIGH 7.5
  • TI-2026-02474 @fastify/middie has an improper path normalization vulnerability CVSS 4.0HIGH 8.2

Sources