@fastify/middie vulnerable to path-scoped middleware bypass via absolute-form request target
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
@fastify/middie versions >= 9.1.0 and before 9.3.4 decide whether to run path-scoped middleware by matching against the raw request target, while the Fastify router resolves an absolute-form request target to its path before dispatching. Because the two layers evaluate different strings, a request using an absolute-form target reaches the route handler while the path-scoped middleware, such as authentication or authorization, is skipped. An unauthenticated network attacker can use this to bypass path-based access controls in a Fastify application that relies on middie for those controls. Users should upgrade to @fastify/middie 9.3.4 or later.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA @fastify/middie (@fastify/middie) Fixed in 9.3.4
Timeline
- 2026-10-02 Threatist record created from CVE-2026-85184
References
More Fastify/middie vulnerabilities
- TI-2026-05498 @fastify/middie vulnerable to middleware authentication bypass in child plugin scopes CVSS 3.1CRITICAL 9.1
- TI-2026-17725 Fastify Middie Middleware Path Bypass CVSS 3.1HIGH 8.8
- TI-2026-12029 @fastify/middie vulnerable to authorization bypass via encoded slash in path parameter values CVSS 3.1CRITICAL 9.1
- TI-2026-26176 @fastify/middie vulnerable to middleware bypass via deprecated ignoreDuplicateSlashes option CVSS 3.1CRITICAL 9.1
- TI-2026-12013 @fastify/middie standalone engine vulnerable to Denial of Service via malformed percent-encoded paths CVSS 3.1HIGH 7.5
- TI-2026-02474 @fastify/middie has an improper path normalization vulnerability CVSS 4.0HIGH 8.2
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences