YesWiki has Persistant Blind XSS at "/?BazaR&vue=consulter"
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
YesWiki is a wiki system written in PHP. Prior to version 4.6.0, a stored and blind XSS vulnerability exists in the form title field. A malicious attacker can inject JavaScript without any authentication via a form title that is saved in the backend database. When any user visits that injected page, the JavaScript payload gets executed. This issue has been patched in version 4.6.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| YesWiki | yeswiki | before 4.6.0 | 4.6.0 | Patch available | CNA |
| — | yeswiki/yeswiki (Packagist) | before 4.6.0 | 4.6.0 | Patch available | GHSA-37fq-47qj-6j5j |
- yeswiki VendorYesWiki Affected before 4.6.0 Fixed in 4.6.0 Patch available CNA
- yeswiki/yeswiki (Packagist) Vendor— Affected before 4.6.0 Fixed in 4.6.0 Patch available GHSA-37fq-47qj-6j5j
Remediation
- Fix · CNA yeswiki (YesWiki) Fixed in 4.6.0
- Fix · GHSA-37fq-47qj-6j5j yeswiki/yeswiki (Packagist) Fixed in 4.6.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-34598
- 2026-10-03 Alias added: GHSA-37fq-47qj-6j5j
References
More Yeswiki vulnerabilities
- TI-2025-29089 YesWiki Vulnerable to Unauthenticated Site Backup Creation and Download CVSS 3.1CRITICAL 10.0
- TI-2024-34399 Use of a Broken or Risky Cryptographic Algorithm in YesWiki CVSS 3.1CRITICAL 9.9
- TI-2025-22392 Path Traversal allowing arbitrary read of files in Yeswiki CVSS 3.1HIGH 8.6
- TI-2025-17784 YesWiki Vulnerable to Unauthenticated DOM Based XSS CVSS 3.1HIGH 7.6
- TI-2025-29087 YesWiki Vulnerable to Stored XSS in Comments CVSS 4.0MEDIUM 6.3
- TI-2025-29090 YesWiki Vulnerable to Unauthenticated Reflected Cross-site Scripting CVSS 3.1HIGH 7.6
Sources
- CVE-2026-34598 · CVE Program
- CVE-2026-34598 · NVD
- FIRST EPSS
- GHSA-37fq-47qj-6j5j · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences