Denial of service via DoH3 queries
Priority LOW 18CWE-705Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
An attacker might be able to delay the processing of DoH3 queries by sending DoH3 GET queries with an invalid DATA frame.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00402 34th percentileScored 2026-11-07
Fix Fixed DNSdist (PowerDNS): 1.9.15, 2.0.7
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA DNSdist (PowerDNS) Fixed in 1.9.15, 2.0.7
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
PowerDNS DNSdist 1.9.15, 2.0.7
6 records Highest priority Priority LOW 6 LOW
Other records, highest priority first
- TI-2026-29022 Denial of service via crafted DoH3 queriesPriority LOW 31
- TI-2026-29020 Denial of service via IXFR queriesPriority LOW 31
- TI-2026-29021 Out-of-bounds read in SetMacAddrActionPriority LOW 23
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2026-40208
- 2026-10-03 Alias added: GHSA-2cpw-vgr2-pw3h
References
More PowerDNS vulnerabilities
- TI-2023-27571 Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related… CVSS 3.1HIGH 7.5
- TI-2023-27773 The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance… CVSS 3.1HIGH 7.5
- TI-2015-01678 The label decompression functionality in PowerDNS Recursor 3.5.x, 3.6.x before 3.6.3, and… CVSS 2.0HIGH 7.8
- TI-2021-14878 PowerDNS Authoritative Server 4.5.0 before 4.5.1 allows anybody to crash the process by… CVSS 3.1HIGH 7.5
- TI-2016-04703 PowerDNS (aka pdns) Authoritative Server before 3.4.10 does not properly handle a . CVSS 3.0HIGH 7.5
- TI-2018-12065 Out-of-bounds read in [UNKNOWN] pdns-recursor CVSS 3.0HIGH 7.5
Sources
- CVE-2026-40208 · CVE Program
- CVE-2026-40208 · NVD
- FIRST EPSS
- GHSA-2cpw-vgr2-pw3h · GitHub Advisory Database · CC BY 4.0
- CVE-2026-40208 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences